Bug 52381 - latest kpersonaliser uses wrong charset for Russian language
latest kpersonaliser uses wrong charset for Russian language
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-23 07:23 EDT by Leonid Kanter
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-23 07:23:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonid Kanter 2001-08-23 07:23:19 EDT
Description of Problem:

kdebase-2.2-charset.patch set iso-8859-5 charset for Russian language:

+  else if(lang == "ru")
+         charset="iso-8859-5";

It's wrong, must be koi8-r (see anaconda's lang-table for Russian).
There is also no any ISO-8859-5 fonts except for fixed that is not enough
for kde.

Version-Release number of selected component (if applicable):

kdebase-2.2-5
Comment 1 Bernhard Rosenkraenzer 2001-08-23 11:26:36 EDT
Fixed in 2.2-7...
The reason I set it to 8859-5 initially is that that's what KDE's locale files 
suggest . I'll simply trust you on this one, I don't speak Russian.
Comment 2 Leonid Kanter 2001-08-23 12:00:44 EDT
I know that you don't speak Russian. But you can trust also anaconda/lang-table.
Here is the line:

Russian         ru      cyr-sun16       koi8-r          ru_RU.koi8r     ru
Comment 3 Bernhard Rosenkraenzer 2001-08-23 12:20:12 EDT
What anaconda claims is not necessarily right for KDE - if iso-8859-5 and 
kio8-r are very different, a translated string written for one will not 
necessarily display correctly on the other...
So if kde-i18n stuff is written in iso-8859-5 and not properly UTF8 encoded, 
it will display garbage even if koi8-r is the correct charset.

However, I'm quite sure all the kde-i18n stuff is UTF8 by now.

Comment 4 Leonid Kanter 2001-08-23 12:54:15 EDT
Yes, all russian .po files from kde are utf8-encoded. But 1) iso8859-5 fonts are
still needed, 2) encodings are quite different, and if file was created with
console or gnome text editor, it must be convertEd by iconv first to edit it in
iso5 editor.

[leon@p504 SRPMS]$ xlsfonts | grep -c iso8859-5
50
(-misc-fixed-* only)
[leon@p504 SRPMS]$ xlsfonts | grep -c koi8-r
375
Actually iso8859-5 live only on Sun Solaris. Most part of Linux and *BSD russian
 community uses koi8-r and small part uses microsoft-cp1251. BTW I have packages
with 75dpi fonts for iso8859-5 and cp1251, and they may be sceduled for next Red
Hat Linux release. Bulgarians and Byelorussians will enjoy cp1251 fonts very much.

Note You need to log in before you can comment on or make changes to this bug.