Bug 523817 - ABRT and user friendliness - a rather terrifying story
Summary: ABRT and user friendliness - a rather terrifying story
Keywords:
Status: CLOSED DUPLICATE of bug 489624
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jiri Moskovcak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-16 18:51 UTC by Kamil Páral
Modified: 2018-04-11 09:38 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-06 15:26:51 UTC


Attachments (Terms of Use)

Description Kamil Páral 2009-09-16 18:51:16 UTC
Description of problem:
Today a pulseaudio crashed when running from a Test Day LiveCD. Abrt icon shows up, good. I click on it, GUI pops up, great. I see an item saying pulseaudio, I see "Not reported" sign, nice. But how to report it? No big button anywhere. Right click on the item - nothing happens. Looking at the system menu - nothing there. There is one option left - the icon with the (probably) save icon. What does it do? No tooltip, no name, nothing! Ok, I will risk that, it's just a livecd. I click it, heart pounding. Long time waiting and watching dialog where the last line is always cut off, not really seeing much. "Report" screen pops up. I write a long comment what I did before it crashed. The dialog does not wrap words so it's a very long single line, I have to constantly scroll left and right. Hit Send and confirm all warnings. I get an error message saying I have not filled in my bugzilla account credentials. It hadn't asked! On top of that, at the bottom there is a line "This crash has been reported, you can find the report(s) at:"... and that's all, rest is blank. So was it reported or not? Weird. Alright, what now? After a while I find Bugzilla plugin in Preferences, so I enter my credentials. The Apply and Cancel button are swapped, therefore I hit Cancel unintentionally to confirm it. Argh. Ok, I fill it again, this time pressing Apply. I press the green button again to report the bug again. Oh my god, my previous comment is lost. F**k! So much time spent on writing it. Alright, what I wouldn't do for the community. I write the comment once more. I hit Send, Yes, Yes and the bug is finally reported. Oof!

Guys! Developers, developers, developers! :) Try to look at it also from an end-user perspective! I had feelings like tearing the software to pieces, what about them? They will probably end at the green button hesitation.

I believe I don't have to report you single bugs for all problems described in the text, you can surely extract them from it.

Version-Release number of selected component (if applicable):
abrt-0.0.8.5-1.fc12.x86_64

How reproducible:
always

Comment 1 Jiri Moskovcak 2009-09-17 09:16:12 UTC
Hi,
you should try double click :)
I know that the GUI needs a LOT work and I'm working on it right now.

Jirka

Comment 2 Jiri Moskovcak 2009-09-22 11:01:02 UTC
Thee has been some progress in version 0.0.9 which should hit the repo again:
- added context menu on right click
- comment and "How to reproduce" are now saved, when user clicks "Send" in report dialog so user doesn't have to fill them again if reporting fails.


The next step: I'd like to convert the GUI into wizard which guide the user through the whole process (BZ account creating if necessary , required credential filling, etc..).

Jirka

Comment 3 Denys Vlasenko 2009-10-06 15:26:51 UTC

*** This bug has been marked as a duplicate of bug 489624 ***


Note You need to log in before you can comment on or make changes to this bug.