Bug 523821 - Satellite 5.1.1 to 5.3 upgrade on RHEL 4 doesn't work
Summary: Satellite 5.1.1 to 5.3 upgrade on RHEL 4 doesn't work
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades
Version: 530
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Milan Zázrivec
QA Contact: Brandon Perkins
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-16 19:05 UTC by Albert Hopkins
Modified: 2018-10-20 04:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-07 05:06:29 UTC


Attachments (Terms of Use)

Description Albert Hopkins 2009-09-16 19:05:31 UTC
Upgrading from Sat 5.1.1 to 5.3 on RHEL4 is not possible:

After several attempts at this it seems that it is not possible to upgrade to 5.3 on RHEL 4.  The primary issue is dependencies and order of steps to perform upgrade.

First, the updating of the certificate comes later in the upgrade steps; however, many dependencies are not available until you are subscribed to the Satellite 5.3 channel.

Second, several dependencies can only be satisfied when subscribed to RHEL 4 development channels.

Finally, elfutils-libs appears to be  a dependency; however, it is only available in the RHEL 5 channels.

Comment 2 Milan Zázrivec 2009-09-16 19:49:23 UTC
What's the name of the 5.3.0 ISO file you used? Are you absolutely sure
you did not use the RHEL-5 version?

For RHEL-4, x86_64 the iso you are looking for is:

  redhat-rhn-satellite-5.3-as-x86_64-4-embedded-oracle.iso

or in case you use external database:

  redhat-rhn-satellite-5.3-as-x86_64-4.iso

Comment 5 Clifford Perry 2009-10-07 05:06:29 UTC
Private comments indicate resolved through Support. 

Closing bug out.


Note You need to log in before you can comment on or make changes to this bug.