Bug 523839 - MinimalPlatform option (feature request)
Summary: MinimalPlatform option (feature request)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL: https://fedoraproject.org/wiki/Featur...
Whiteboard:
: 528474 566999 (view as bug list)
Depends On:
Blocks: 519838 554536 575256
TreeView+ depends on / blocked
 
Reported: 2009-09-16 20:03 UTC by Renich Bon Ciric
Modified: 2010-03-19 20:41 UTC (History)
7 users (show)

Fixed In Version: anaconda-13.7-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-27 13:58:38 UTC


Attachments (Terms of Use)

Description Renich Bon Ciric 2009-09-16 20:03:26 UTC
Description of problem:
Currently, to install the minimal platform, you need to unselect all the packages, while customizing the package selection.

Version-Release number of selected component (if applicable):
12.25-1.fc12

How reproducible:
Start a Fedora 12 alpha (rawhide) graphical installation. When asked, select "customize packages"... or something like that. Unselect everything and Fedora will make the minimal installation

Steps to Reproduce:
1. Start a rawhide graphical installation
2. Get to the point where you can select the packages to install
3. Unselect everything
  
Actual results:
You get the minimal install

Expected results:
You should be able to click an option (possibly, before customization) so it unselects everything for you.

Potentially, there could be a number of minimal installation editions, for example:

- extreme minimal
an extreme version of minimalism (no yum, utils and stuff)

- standard minimal
the current minimal setup

- enhanced minimal
the minimal setup with a few useful tools like wget, X, ssh-clients, etc.

Additional info:
Please, review the discussion seciton of:
https://fedoraproject.org/wiki/Features/MinimalPlatform

Comment 1 Adam Williamson 2009-09-25 15:49:53 UTC
as this is not an approved F12 feature according to http://fedoraproject.org/wiki/Releases/12/FeatureList , it cannot block the final release.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Renich Bon Ciric 2009-09-26 00:36:48 UTC
ok, I understand. What do you propose in order to make it happen? Should I issue a Feature Request on Fedora 12/13?

Thanks!

Comment 3 Adam Williamson 2009-09-26 04:42:57 UTC
not blocking the release doesn't mean it won't happen, just means we won't hold up the release of Fedora 12 if it isn't done by then.

Proposing it as an official feature would be a good way to get it done for F13 if it doesn't happen for F12, though, yes.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 4 Chris Lumens 2009-10-12 17:52:34 UTC
*** Bug 528474 has been marked as a duplicate of this bug. ***

Comment 5 Chris Lumens 2009-10-27 13:58:38 UTC
This will be fixed for F13, though not for F12 because it requires breaking the string freeze.  Thanks for the bug report.

Comment 6 Chris Lumens 2010-02-22 22:49:42 UTC
*** Bug 566999 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.