Bug 523863 - [abrt] crash detected in system-config-samba-1.2.82-1.fc12
Summary: [abrt] crash detected in system-config-samba-1.2.82-1.fc12
Keywords:
Status: CLOSED DUPLICATE of bug 533743
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-samba
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:08997608
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-16 21:56 UTC by Flóki Pálsson
Modified: 2010-04-16 23:56 UTC (History)
224 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-11 08:12:42 UTC


Attachments (Terms of Use)
File: backtrace (6.47 KB, text/plain)
2009-09-16 21:56 UTC, Flóki Pálsson
no flags Details

Description Flóki Pálsson 2009-09-16 21:56:32 UTC
abrt detected a crash.


How to reproduce
-----
1.
2.
3.


Additional information
======


Attached files
----
backtrace

cmdline
-----
/usr/bin/python /usr/bin/system-config-samba 


component
-----
system-config-samba


executable
-----
/usr/bin/system-config-samba


kernel
-----
2.6.31-12.fc12.x86_64


package
-----
system-config-samba-1.2.82-1.fc12


uuid
-----
08997608

Comment 1 Flóki Pálsson 2009-09-16 21:56:36 UTC
Created attachment 361385 [details]
File: backtrace

Comment 2 Flóki Pálsson 2009-10-18 21:27:47 UTC
I can not see this crash in
system-config-samba-1.2.83-1.fc12.noarch

Comment 3 Jóhann B. Guðmundsson 2009-10-20 16:54:24 UTC
For the record I did with system-config-samba-1.2.83-1.fc12.noarch on an i686 and abrt deemed mine as an duplicate and I'm not noticing any new builds in of system-config-samba-1.2.83-1 in koji...

Comment 4 Flóki Pálsson 2009-10-28 20:33:57 UTC
I see this to when adding a new samba user.
When starting s-c-s from menu ans normal user.
with 
system-config-samba-1.2.83-1.fc12.noarch
kernel-2.6.31.5-96.fc12.x86_64
selinux-policy-3.6.32-27.fc12.noarch

there is also sealert se bug 529576 

adding user with s-c-s as root works
but 
[root@flokipal ~]# system-config-samba
account_policy_get: tdb_fetch_uint32 failed for field 1 (min password length), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 2 (password history), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 3 (user must logon to change password), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 4 (maximum password age), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 5 (minimum password age), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 6 (lockout duration), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 7 (reset count minutes), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 8 (bad lockout attempt), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 9 (disconnect time), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 10 (refuse machine password change), returning 0
Added user floki.
[root@flokipal ~]# 
floki5

Comment 5 Flóki Pálsson 2009-10-28 20:40:06 UTC
se also bug  529291

Comment 6 Panagiotis Kalogiratos 2009-10-31 02:30:59 UTC
Indeed this happens when you try to add a user with a normal user and get elevation. Running it as root/su/sudo works properly.

Comment 7 Gian Paolo Mureddu 2009-12-13 23:44:37 UTC
So this problem seems to be linked to PK rather than system-config-samba itself, woudln't it?

Comment 8 Nils Philippsen 2009-12-14 09:40:19 UTC
(In reply to comment #6)
> Indeed this happens when you try to add a user with a normal user and get
> elevation. Running it as root/su/sudo works properly.  

Do you see this error every time you run s-c-services? Do you have SELinux enabled and if yes, does it make a difference if it is set to enforcing or permissive?

Comment 9 Gian Paolo Mureddu 2009-12-14 20:17:22 UTC
(In reply to comment #8)
> Do you see this error every time you run s-c-services? Do you have SELinux
> enabled and if yes, does it make a difference if it is set to enforcing or
> permissive?  

I'm not sure about others, but I do not see this happening with any other s-c- command, only Samba, when run as a regular user. I do have SELinux on its default config for F12, which is enforcing.

Comment 10 Flóki Pálsson 2009-12-14 20:51:11 UTC
(In reply to comment #8)
The situation has changed,  now sealert when starting s-c-s ( Bug 547472)
>Do you see this error every time you run s-c-services?
No. only for s-c-samba.
( s-c-* is ok except s-c-h ( but not  crash))

for s-c-samba
"abrt detected a crash"  was only when adding new samba user.
I did not check if there was difference between    

>Do you have SELinux
>enabled and if yes, does it make a difference if it is set to enforcing or
>permissive? 
I did not check if there was difference between enforcing or permissive.    

but now 
Selinux in permisive mode 
[floki@flokipa ~]$ /usr/bin/system-config-samba
Traceback (most recent call last):
  File "/usr/share/system-config-samba/addUserWin.py", line 174, in
on_add_user_ok_button_clicked
    elif self.samba_backend.userExists(unix_name):
  File "/usr/lib/python2.6/site-packages/scsamba/dbus/proxy/sambaBackend.py",
line 88, in userExists
    return self.dbus_interface.userExists (user)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in
__call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in
call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not
receive a reply. Possible causes include: the remote application did not send a
reply, the message bus security policy blocked the reply, the reply timeout
expired, or the network connection was broken.
^C
[floki@flokipa ~]$ 
---------------------------------------
and 
Se  Bug 547472 for enforcing mode

Comment 11 Dagan McGregor 2009-12-15 03:29:21 UTC
I have the same crash error as above, but my backtrace doesn't appear to be added here. Just me on the CC list :\

I also have F12 with the SELinux enforcing, the default targetted policy 
Name       : selinux-policy-targeted
Arch       : noarch
Version    : 3.6.32
Release    : 55.fc12

--------------------------------------
UUID: 08997608
architecture: x86_64
cmdline: /usr/bin/python /usr/bin/system-config-samba 
component: system-config-samba
executable: /usr/bin/system-config-samba
kernel: 2.6.31.6-166.fc12.x86_64
package: system-config-samba-1.2.83-1.fc12
release: Fedora release 12 (Constantine)
uuid: 08997608

Comment
-----
Repeatable every time, trying to open from System -> Administration -> Samba as standard user.

Does not crash when run as root, from command line. Shows the config as expected.

How to reproduce
-----
1. Try to open system-config-samba as standard user
2. Enter authentication details
3. Get this crash message

backtrace
-----
Summary: TB08997608 connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Traceback (most recent call last):
  File "/usr/bin/system-config-samba", line 53, in <module>
    mainWindow.MainWindow (debug_flag = debug_flag, use_dbus = use_dbus)
  File "/usr/share/system-config-samba/mainWindow.py", line 97, in __init__
    self.samba_data = sambaConfig.SambaConfig (self.samba_backend)
  File "/usr/lib/python2.6/site-packages/scsamba/core/sambaConfig.py", line 29, in __init__
    self.parseFile ()
  File "/usr/lib/python2.6/site-packages/scsamba/core/sambaConfig.py", line 32, in parseFile
    return self.parse (self.backend.readSmbConf ())
  File "/usr/lib/python2.6/site-packages/scsamba/dbus/proxy/sambaBackend.py", line 48, in readSmbConf
    return self.dbus_interface.readSmbConf ()
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Local variables in innermost frame:
byte_arrays: False
self: <dbus._dbus.SystemBus (system) at 0xf73ef0>
args: ()
utf8_strings: False
bus_name: :1.65
get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
object_path: /org/fedoraproject/Config/Samba/Backend
timeout: -1.0
signature: None
dbus_interface: org.fedoraproject.Config.Samba.Backend
message: <dbus.lowlevel.MethodCallMessage object at 0xcf5660>
method: readSmbConf

Comment 12 cyrushmh 2009-12-22 05:31:10 UTC
I'm can't use samba ,that I 
1,click to start system-config-samba.
2,type my root password,
3,then abrt tell me report bug.

 已安装的软件包
名称       : system-config-samba
架构          : noarch
版本          : 1.2.83
次要版本          : 1.fc12
大小          : 935 k
仓库          : installed
From repo  : anaconda-InstallationRepo-200911081854.i386
摘要          : Samba 服务器配置工具
URL        : http://fedorahosted.org/system-config-samba
授权方式        : GPLv2+
描述          : system-config-samba 是用来创建、修改和删除
              : samba 共享的图形化用户界面。

Comment 13 Dagan McGregor 2009-12-22 10:29:57 UTC
Please note: Because of the original Backtrace attached to this bugs, ALL USERS who are still experiencing bugs with system-config-samba crashing with the "DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply." error are being directed here, added to the CC list, and no further backtraces are being logged in Bugzilla.

This bug is NOT fixed. The problem with system-config-samba remains.

Users cannot open system-config-samba as a regular user. This is regardless of adding a user or not. I cannot even get the application to open, let alone open long enough to try adding or changing anything.

Someone needs to reassign this bug, because I would expect a very large number of ABRT reports are going into a blackhole due to this issue already being closed, but NOT fixed for users.

Comment 14 Nils Philippsen 2009-12-22 17:31:31 UTC
(In reply to comment #13)
> Please note: Because of the original Backtrace attached to this bugs, ALL USERS
> who are still experiencing bugs with system-config-samba crashing with the
> "DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply."
> error are being directed here, added to the CC list, and no further backtraces
> are being logged in Bugzilla.

Unfortunately, many issues cause that specific dbus exception.

> This bug is NOT fixed. The problem with system-config-samba remains.
> 
> Users cannot open system-config-samba as a regular user. This is regardless of
> adding a user or not. I cannot even get the application to open, let alone open
> long enough to try adding or changing anything.
> 
> Someone needs to reassign this bug, because I would expect a very large number
> of ABRT reports are going into a blackhole due to this issue already being
> closed, but NOT fixed for users.  

I've meanwhile had the chance to see system-config-samba failing and it seemed to be a SELinux policy issue, which seems to have been fixed in selinux-policy-targeted-3.6.32-59.fc12 which is available from updates-testing. If you have SELinux active (enforcing or permissive), please update to at least this version. I did it this way:

yum --enablerepo=updates-testing update selinux-policy-\* policycoreutils\*

Comment 15 Dagan McGregor 2009-12-22 23:11:24 UTC
I had updated selinux-policy packages from testing after earlier reading on related bugs, but didn't try policycoreutils, so will update them both again and see how that goes.

Thanks for the update.

Comment 16 Rodolfo Paiz 2010-01-14 05:52:55 UTC
system-config-samba crashed on me multiple times (every single time, in fact) while attempting to add myself (a non-root user) as a Samba user to create one share. Attempting to add a Samba user would kill it immediately.

Tried a ton of things to get it to open up "nicely", i.e. without invoking it as root, to see if I could figure it out. No such luck. Invoked system-config-samba from a shell as root, and voilà!... instant functionality. Was logged in through Samba in 10 seconds.

I've been away from Linux for a few years, but at least I knew how to test stuff and try different things and to check here. If I hadn't found this bug, or if I were a newbie user, I'd be SOL in a big way.

Gotta fix this one, whatever the cause is. Not having Samba functional is a real issue. :-)

Comment 17 Reggie Pearce 2010-02-07 17:16:13 UTC
I am running a fairly new installed of FC 12. I disabled SELinux and still have this issue.  
I am going to try:
yum --enablerepo=updates-testing update selinux-policy-\* policycoreutils\*

Just for the heck of it.

Comment 18 Reggie Pearce 2010-02-07 18:13:53 UTC
So I ran: 

yum --enablerepo=updates-testing update selinux-policy-\* policycoreutils\*

Still have the same problem using Samba Server Configuration tool from the System | Administration menu item in the GUI.



Output of backtrace:

Summary: TB08997608 connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Traceback (most recent call last):
  File "/usr/share/system-config-samba/addUserWin.py", line 174, in on_add_user_ok_button_clicked
    elif self.samba_backend.userExists(unix_name):
  File "/usr/lib/python2.6/site-packages/scsamba/dbus/proxy/sambaBackend.py", line 88, in userExists
    return self.dbus_interface.userExists (user)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Local variables in innermost frame:
byte_arrays: False
self: <dbus._dbus.SystemBus (system) at 0x25c6e90>
args: ('reggie',)
utf8_strings: False
bus_name: dbus.UTF8String(':1.67')
get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
object_path: '/org/fedoraproject/Config/Samba/Backend'
timeout: -1.0
signature: u's'
dbus_interface: 'org.fedoraproject.Config.Samba.Backend'
message: <dbus.lowlevel.MethodCallMessage object at 0x2342648>
method: 'userExists'

Comment 19 Nils Philippsen 2010-02-09 11:22:02 UTC
All: please check system-config-samba-1.2.84-1.fc12 which should hit updates-testing shortly, meanwhile you can grab it directly from Koji:

http://koji.fedoraproject.org/koji/buildinfo?buildID=154265

Comment 20 Sean 2010-02-10 15:57:38 UTC
Tried the testing update and got the following:

ummary: TB08997608 connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Traceback (most recent call last):
  File "/usr/share/system-config-samba/addUserWin.py", line 175, in on_add_user_ok_button_clicked
    elif self.samba_backend.userExists(unix_name):
  File "/usr/lib/python2.6/site-packages/scsamba/dbus/proxy/sambaBackend.py", line 88, in userExists
    return self.dbus_interface.userExists (user)
  File "/usr/lib/python2.6/site-packages/slip/dbus/proxies.py", line 49, in __call__
    return dbus.proxies._ProxyMethod.__call__(self, *args, **kwargs)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Local variables in innermost frame:
byte_arrays: False
self: <dbus._dbus.SystemBus (system) at 0xde18f0>
args: ('games',)
utf8_strings: False
bus_name: dbus.UTF8String(':1.466')
get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
object_path: '/org/fedoraproject/Config/Samba/Backend'
timeout: -1.0
signature: u's'
dbus_interface: 'org.fedoraproject.Config.Samba.Backend'
message: <dbus.lowlevel.MethodCallMessage object at 0xf8d798>
method: 'userExists'

Comment 21 Nils Philippsen 2010-02-10 16:49:24 UTC
(In reply to comment #20)
> Tried the testing update and got the following:

Please test 1.2.85 which should hit updates-testing shortly (or grab it from koji), .84 is missing half of the fix.

Comment 22 Nils Philippsen 2010-02-10 17:11:02 UTC
BTW, grab 1.2.85 from koji here:

http://koji.fedoraproject.org/koji/buildinfo?buildID=155314

Comment 23 Sean 2010-02-10 19:21:32 UTC
Tried the testing update and got the following:

ummary: TB08997608 connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Traceback (most recent call last):
  File "/usr/share/system-config-samba/addUserWin.py", line 175, in on_add_user_ok_button_clicked
    elif self.samba_backend.userExists(unix_name):
  File "/usr/lib/python2.6/site-packages/scsamba/dbus/proxy/sambaBackend.py", line 88, in userExists
    return self.dbus_interface.userExists (user)
  File "/usr/lib/python2.6/site-packages/slip/dbus/proxies.py", line 49, in __call__
    return dbus.proxies._ProxyMethod.__call__(self, *args, **kwargs)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Local variables in innermost frame:
byte_arrays: False
self: <dbus._dbus.SystemBus (system) at 0xde18f0>
args: ('games',)
utf8_strings: False
bus_name: dbus.UTF8String(':1.466')
get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
object_path: '/org/fedoraproject/Config/Samba/Backend'
timeout: -1.0
signature: u's'
dbus_interface: 'org.fedoraproject.Config.Samba.Backend'
message: <dbus.lowlevel.MethodCallMessage object at 0xf8d798>
method: 'userExists'

Comment 24 Sean 2010-02-10 19:23:15 UTC
Please ignore comment 23.  Refresh issues... :)

Comment 25 Sean 2010-02-10 19:36:52 UTC
Tested using 1.2.85 (from koji)  when I try and add a user the program freezes up. No ABRT popup and I can't close the windows, have to kill the app.

Not sure how to get a backtrace for you.

Comment 26 Christoph Wickert 2010-02-10 19:46:03 UTC
This is already discussed in bug 533743 and I already provided the backtrace
there.

Comment 27 Nils Philippsen 2010-02-11 08:12:42 UTC
(In reply to comment #26)
> This is already discussed in bug 533743 and I already provided the backtrace
> there.    

Let's continue this there. While this is the older bug, bug #533743 contains more info.

*** This bug has been marked as a duplicate of bug 533743 ***


Note You need to log in before you can comment on or make changes to this bug.