Bug 523866 - [abrt] crash detected in setroubleshoot-server-2.2.28-1.fc12
Summary: [abrt] crash detected in setroubleshoot-server-2.2.28-1.fc12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:ecbede9d
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-16 22:41 UTC by Nicolas Mailhot
Modified: 2010-03-27 01:03 UTC (History)
3 users (show)

Fixed In Version: setroubleshoot-2.2.69-1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-27 01:03:32 UTC


Attachments (Terms of Use)
File: backtrace (568 bytes, text/plain)
2009-09-16 22:42 UTC, Nicolas Mailhot
no flags Details

Description Nicolas Mailhot 2009-09-16 22:41:58 UTC
abrt detected a crash.


How to reproduce
-----
1.
2.
3.


Additional information
======


Attached files
----
backtrace

cmdline
-----
/usr/bin/python -E /usr/bin/sealert -s 


component
-----
setroubleshoot


executable
-----
/usr/bin/sealert


kernel
-----
2.6.31-17.fc12.x86_64


package
-----
setroubleshoot-server-2.2.28-1.fc12


uuid
-----
ecbede9d

Comment 1 Nicolas Mailhot 2009-09-16 22:42:02 UTC
Created attachment 361391 [details]
File: backtrace

Comment 2 Daniel Walsh 2009-09-17 17:48:24 UTC
How did you get this to happen?

Comment 3 Nicolas Mailhot 2009-09-26 10:16:07 UTC
I think a lot of selinux applet crashes are due to its bad ui which is overfond of badly synchronized popups. I'll bet most of them assume the window that spawned them never changes state during their lifetime, which is wrong (especially since sealert can be slow as a pig and the user is not likely to wait doing nothing while it processes an entry)

Besides, this is just bad ui. Inline notification (like the firefox yellow bar) is much better than opening lots of small popups all over the screen.

Comment 4 Daniel Walsh 2009-09-28 20:45:21 UTC
I really do not know what you mean.  What popups?  The notification that a alert has arrived?

Comment 5 Nicolas Mailhot 2009-09-29 05:41:50 UTC
the "report this bug" and "this bug was filed as ..." popups

Comment 6 Daniel Walsh 2009-09-29 12:05:32 UTC
What would you like to see?  Do you dislike the report the bug being a popup windoow?  Would you rather see the report this bug change to the "this bug was filed as" window?

Comment 7 Nicolas Mailhot 2009-09-29 12:30:28 UTC
It would certainly be nicer if sealert did all its work in a single window withour any popup

Comment 8 Daniel Walsh 2009-09-29 12:36:22 UTC
Patches Accepted :^).

If I get help I will suggest your changes.  Most changes were done with a Summer Intern, hopefully I will get some back over Winter break or next summer.

Comment 9 Bug Zapper 2009-11-16 12:31:47 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 10 Daniel Walsh 2010-03-18 15:10:01 UTC
Fixed in setroubleshoot-2.2.69-1.fc12

Comment 11 Fedora Update System 2010-03-18 15:13:25 UTC
setroubleshoot-2.2.69-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/setroubleshoot-2.2.69-1.fc12

Comment 12 Fedora Update System 2010-03-23 02:18:37 UTC
setroubleshoot-2.2.69-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update setroubleshoot'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/setroubleshoot-2.2.69-1.fc12

Comment 13 Fedora Update System 2010-03-27 01:03:19 UTC
setroubleshoot-2.2.69-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.