Bug 523880 - Rednotebook fails on start
Summary: Rednotebook fails on start
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rednotebook
Version: 11
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Christoph Wickert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-17 01:59 UTC by Mark F. Liu
Modified: 2009-09-30 08:15 UTC (History)
4 users (show)

Fixed In Version: 0.8.6.1-1.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-30 07:51:21 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 424550 0 None None None Never

Description Mark F. Liu 2009-09-17 01:59:06 UTC
Description of problem:
Rednotebook fails on start.

Version-Release number of selected component (if applicable):
0.8.6

How reproducible:
Every time.

Steps to Reproduce:
1.Just start it, and it fails.
2.
3.
  
Actual results:
It seemed crashed.

Expected results:
Rednotebook starts its GUI and I can use it.

Additional info:
(Never mind those characters if they look strange, they are Chinese saying: "Duplicated object ID "cellrenderertext2" occurs in Line 562 [It occurred in Line 162 previously.])

$ rednotebook
INFO     Writing log to file "/home/marklf/.rednotebook/rednotebook.log"
INFO     Using libyaml for loading and dumping
INFO     AppDir: /usr/lib/python2.6/site-packages/rednotebook
INFO     BaseDir: /usr/lib/python2.6/site-packages
INFO     The config file /usr/lib/python2.6/site-packages/rednotebook/files/default.cfg was read
INFO     The config file /home/marklf/.rednotebook/configuration.cfg was read
INFO     Running in portable mode: 0
INFO     First Start: False
INFO     RedNotebook version: 0.8.6
INFO     System info: machine: i686, platform: Linux-2.6.30.5-43.fc11.i586-i686-with-fedora-11-Leonidas, processor: i686, python_version: 2.6.0, release: 2.6.30.5-43.fc11.i586, system: Linux, GTK version: (2, 16, 6), PyGTK version: (2, 14, 1), Yaml version: 3.08, 
ERROR    An error occured while loading the GUI: 重复的对象ID“cellrenderertext2”出现在第 562 行(之前出现在第 162 行)
ERROR    RedNotebook requires at least gtk+ 2.14. If you cannot update gtk, you might want to try an older version of RedNotebook.

Comment 1 Jason Knell 2009-09-17 03:46:05 UTC
I just updated my system tonight and the update broke rednotebook; Same issue. 


$rednotebook
INFO     Writing log to file "/home/Jason/.rednotebook/rednotebook.log"
INFO     Using libyaml for loading and dumping
INFO     AppDir: /usr/lib/python2.6/site-packages/rednotebook
INFO     BaseDir: /usr/lib/python2.6/site-packages
INFO     The config file /usr/lib/python2.6/site-packages/rednotebook/files/default.cfg was read
INFO     The config file /home/Jason/.rednotebook/configuration.cfg was read
INFO     Running in portable mode: 0
INFO     First Start: False
INFO     RedNotebook version: 0.8.6
INFO     System info: machine: i686, platform: Linux-2.6.30.5-43.fc11.i686.PAE-i686-with-fedora-11-Leonidas, processor: i686, python_version: 2.6.0, release: 2.6.30.5-43.fc11.i686.PAE, system: Linux, GTK version: (2, 16, 6), PyGTK version: (2, 14, 1), Yaml version: 3.08,
ERROR    An error occured while loading the GUI: Duplicate object id 'cellrenderertext2' on line 562 (previously on line 162)
ERROR    RedNotebook requires at least gtk+ 2.14. If you cannot update gtk, you might want to try an older version of RedNotebook.

Comment 2 Christoph Wickert 2009-09-17 09:22:19 UTC
No problems here:

$ rednotebook 
INFO     Writing log to file "/home/chris/.rednotebook/rednotebook.log"
INFO     Using libyaml for loading and dumping
INFO     AppDir: /usr/lib/python2.6/site-packages/rednotebook
INFO     BaseDir: /usr/lib/python2.6/site-packages
INFO     The config file /usr/lib/python2.6/site-packages/rednotebook/files/default.cfg was read
INFO     The config file /home/chris/.rednotebook/configuration.cfg was read
INFO     Running in portable mode: 0
INFO     First Start: False
INFO     RedNotebook version: 0.8.6
INFO     System info: machine: x86_64, platform: Linux-2.6.30.5-43.fc11.x86_64-x86_64-with-fedora-11-Leonidas, processor: x86_64, python_version: 2.6.0, release: 2.6.30.5-43.fc11.x86_64, system: Linux, GTK version: (2, 16, 5), PyGTK version: (2, 14, 1), Yaml version: 3.08, 
INFO     Cloud ignore list: ['comma', 'filter', 'separated', 'these', 'words']
INFO     Opening journal at /home/chris/.rednotebook/data
INFO     Connected Signals: 1 2 3 6 15 20 

I wonder why you guys have gtk 2.16.6 while I still have 2.16.5. I can't see 2.16.6 on my mirrors, but I do see it was pushed two days ago.

What locales are you using?

Comment 3 Mark F. Liu 2009-09-17 10:30:16 UTC
I am using simplified Chinese. Here is my locales:

$ locale
LANG=zh_CN.UTF-8
LC_CTYPE="zh_CN.UTF-8"
LC_NUMERIC="zh_CN.UTF-8"
LC_TIME="zh_CN.UTF-8"
LC_COLLATE="zh_CN.UTF-8"
LC_MONETARY="zh_CN.UTF-8"
LC_MESSAGES="zh_CN.UTF-8"
LC_PAPER="zh_CN.UTF-8"
LC_NAME="zh_CN.UTF-8"
LC_ADDRESS="zh_CN.UTF-8"
LC_TELEPHONE="zh_CN.UTF-8"
LC_MEASUREMENT="zh_CN.UTF-8"
LC_IDENTIFICATION="zh_CN.UTF-8"
LC_ALL=

Comment 4 Christoph Wickert 2009-09-17 10:33:09 UTC
Great, thanks. After manually upgrading to 2.16.6 I can reproduce the error and I already fixed it. It was a trivial fix and had nothing to do with the locales.

An update is on it's way. Thanks both of you for your reports.

Comment 5 Fedora Update System 2009-09-17 10:39:39 UTC
rednotebook-0.8.6-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/rednotebook-0.8.6-2.fc11

Comment 6 Christoph Wickert 2009-09-17 13:40:32 UTC
Uh, upstream already released 0.8.6.1 with a fix on September 4th, but never announced it.

Comment 7 Fedora Update System 2009-09-17 14:01:02 UTC
rednotebook-0.8.6.1-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/rednotebook-0.8.6.1-1.fc11

Comment 8 Mark F. Liu 2009-09-18 07:45:09 UTC
Thanks. I will wait for the update from repo.

Comment 9 Fedora Update System 2009-09-19 00:09:47 UTC
rednotebook-0.8.6.1-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rednotebook'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9727

Comment 10 Mark F. Liu 2009-09-19 02:23:48 UTC
Thanks! The update is applied and Rednotebook is back to normal.

Comment 11 Mark F. Liu 2009-09-19 02:26:56 UTC
Am I right to close it? Well, I am new to bugzilla, forgive me if I was wrong.

Comment 12 Christoph Wickert 2009-09-19 12:45:25 UTC
(In reply to comment #11)
> Am I right to close it? Well, I am new to bugzilla, forgive me if I was wrong.  

No problem, Mark. We leave this bug open and the Fedora update system will automatically update it's status and close the bug with the proper resolution once the update is actually in the repos.

Now the proper status would be "ON_QA" because the package was released for testing. When it becomes stable, the bug will be closed ERRATA.

For more info on bugzilla's bug statuses, pls see:
https://bugzilla.redhat.com/page.cgi?id=fields.html#status

Comment 13 Mark F. Liu 2009-09-19 16:36:11 UTC
Thanks for your help, Christoph! I will check it out.

Comment 14 Fedora Update System 2009-09-29 14:29:45 UTC
rednotebook-0.8.6.1-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 J. Randall Owens 2009-09-30 06:17:10 UTC
Doesn't seem any better.

$ rpm -q rednotebook
rednotebook-0.8.6-1.fc11.noarch
$ rednotebook
INFO     Writing log to file "/home/jrowens/.rednotebook/rednotebook.log"
INFO     Using libyaml for loading and dumping
INFO     AppDir: /usr/lib/python2.6/site-packages/rednotebook
INFO     BaseDir: /usr/lib/python2.6/site-packages
INFO     The config file /usr/lib/python2.6/site-packages/rednotebook/files/default.cfg was read
INFO     The config file /home/jrowens/.rednotebook/configuration.cfg was read
INFO     Running in portable mode: 0
INFO     First Start: False
INFO     RedNotebook version: 0.8.6
INFO     System info: machine: x86_64, platform: Linux-2.6.30.5-43.fc11.x86_64-x86_64-with-fedora-11-Leonidas, processor: x86_64, python_version: 2.6.0, release: 2.6.30.5-43.fc11.x86_64, system: Linux, GTK version: (2, 16, 6), PyGTK version: (2, 14, 1), Yaml version: 3.08,
ERROR    An error occured while loading the GUI: Duplicate object id 'cellrenderertext2' on line 562 (previously on line 162)
ERROR    RedNotebook requires at least gtk+ 2.14. If you cannot update gtk, you might want to try an older version of RedNotebook.
Exit 1

Comment 16 Christoph Wickert 2009-09-30 07:51:21 UTC
(In reply to comment #15)
> Doesn't seem any better.
> 
> $ rpm -q rednotebook
> rednotebook-0.8.6-1.fc11.noarch

This is still the old version, please note the difference between
0.8.6-1 and
0.8.6.1-1

Please wait another day until the update has reached all mirrors and reopen the bug, if you can still reproduce it with 0.8.6.1-1.

Comment 17 J. Randall Owens 2009-09-30 08:15:09 UTC
Yes, as soon as I got home and saw it in my rsync log, I realized the difference.  Sorry about that.


Note You need to log in before you can comment on or make changes to this bug.