Bug 52390 - ucd-snmp-utils missing dependecy on Perl Tk support.
Summary: ucd-snmp-utils missing dependecy on Perl Tk support.
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: ucd-snmp (Show other bugs)
(Show other bugs)
Version: roswell
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-23 13:38 UTC by lars
Modified: 2015-03-05 01:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-23 13:38:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description lars 2001-08-23 13:38:37 UTC
Description of Problem:

ucd-snmp-utils includes the "tkmib" command, but the rpm has no dependency
on the Perl Tk modules.

Version-Release number of selected component (if applicable):

4.2.1-3

How Reproducible:

Install ucd-snmp-utils without Perl Tk support and try running the 'tkmib'
command.

Steps to Reproduce:

See above.

Actual Results:

Can't locate Tk.pm in @INC (@INC contains: /usr/lib/perl5/5.6.0/i386-linux
/usr/lib/perl5/5.6.0 /usr/lib/perl5/site_perl/5.6.0/i386-linux
/usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl .) at
/usr/bin/tkmib line 43.
BEGIN failed--compilation aborted at /usr/bin/tkmib line 43.

Expected Results:

A nifty GUI mib browser. Or something.

Additional Information:

Comment 1 Phil Knirsch 2001-08-23 13:49:22 UTC
We have been discussing this very problem recently internally and it has been
decided that we remove the tkmib app.

The reason is that we didn't ship the requires perl Tcl/Tk modules in 7.0 and
7.1 (IIRC that is). We definetly won't ship them in the next upcoming release.

Read ya, Phil



Note You need to log in before you can comment on or make changes to this bug.