Bug 523900 - Garbage in KVM guest console when guest runs kernel 2.6.30.5-43.fc11
Summary: Garbage in KVM guest console when guest runs kernel 2.6.30.5-43.fc11
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 11
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F11VirtTarget
TreeView+ depends on / blocked
 
Reported: 2009-09-17 05:52 UTC by Ian Pilcher
Modified: 2010-06-28 14:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-28 14:42:09 UTC


Attachments (Terms of Use)
screenshot of "garbage" console (61.65 KB, image/png)
2009-09-17 05:52 UTC, Ian Pilcher
no flags Details

Description Ian Pilcher 2009-09-17 05:52:29 UTC
Created attachment 361425 [details]
screenshot of "garbage" console

Description of problem:
This is a weird one, and I wasn't sure what component to file it under, or even what architecture to choose.

The problem occurs in a 32-bit Fedora 11 guest, running on a 64-bit Fedora 11 host.  Both are fully updated (as of 2009-09-16).

Everything is fine if I run kernel 2.6.29.4-167.fc11 in the guest.

If I run kernel 2.6.30.5-43.fc11 in the guest, however, the console turns to garbage (screenshot attached) right around the time that the kernel finishes booting.  (I can't tell exactly.  I think I see the blue "Welcome to Fedora" message just before it goes "ugly like zebra".

Version-Release number of selected component (if applicable):
kernel-PAE-2.6.30.5-43.fc11.i686

How reproducible:
100%

Steps to Reproduce:
1.  x86_64 Fedora 11 host system.
2.  32-bit Fedora 11 guest running kernel 2.6.30.5-43.fc11.
3.  Boot guest into runlevel 3.
  
Actual results:
Guest console changes to garbage.

Expected results:
Functional console.

Additional info:

Comment 1 Ian Pilcher 2009-09-17 06:03:35 UTC
I can workaround the problem by using a VESA framebuffer in the guest (e.g. "vga=773" in the guest's kernel command line).

Comment 2 Mark McLoughlin 2009-09-17 13:14:35 UTC
Okay, so this sounds like a 2.6.30 regression

(dirty like zebra ... fun times! :-)

Comment 3 Bug Zapper 2010-04-28 10:25:43 UTC
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Bug Zapper 2010-06-28 14:42:09 UTC
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.