Bug 523911 - no option to choose attachment encoding
Summary: no option to choose attachment encoding
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: thunderbird
Version: 11
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-17 07:25 UTC by Ralf Corsepius
Modified: 2018-04-11 14:13 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-06 02:18:39 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Mozilla Foundation 520702 0 None None None Never

Description Ralf Corsepius 2009-09-17 07:25:09 UTC
Description of problem:

Thunderbird doesn't seem to offer an option to chose the type of encoding attachments.

E.g. thunderbird seems always base64 encode '*diff' attachment.

This practice is frowned upon in developer mailing lists, because it renders reading *.diff's hard.

Version-Release number of selected component (if applicable):
thunderbird-3.0-2.6.b3.fc11.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Attach a *.diff to a mail
2. send it to yourself.
3. Check the mail's source
  
Actual results:

Sent mail contains a base64 encoded attachment:
...
Content-Type: text/plain;
 name="foo.diff"
Content-Transfer-Encoding: base64
Content-Disposition: attachment;


Expected results:
User to select type of attachment.

Additional info:
base64 encoded attachments are frowned upon on all gnu lists.

Provided the fact gnu lists are one of my primary use cases, this defect in thunderbird forces me to stop using thunderbird.

Comment 1 Matěj Cepl 2009-10-06 02:18:39 UTC
We filed this bug in the upstream database (https://bugzilla.mozilla.org/show_bug.cgi?id=520702) and believe that it is more appropriate to let it be resolved upstream.

We will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.


Note You need to log in before you can comment on or make changes to this bug.