Bug 523912 - RFE: Standardised way to override EDID data
Summary: RFE: Standardised way to override EDID data
Keywords:
Status: CLOSED DUPLICATE of bug 582712
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-17 07:38 UTC by birger
Modified: 2018-04-11 16:32 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-26 18:43:51 UTC


Attachments (Terms of Use)

Description birger 2009-09-17 07:38:25 UTC
Description of problem:
In some set-ups it is neccesary to override the EDID data supplied to the graphics card. A few scenarios are:
- KVM switches that filter the screens EDID data and refuse to offer high resolutions or wide-screen resolutions even if they work fine when forced through
- Long cables (20m or longer) where you may need to reduce max bandwith by removing access to the highest resolutions.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
Some easy, standard way to override the EDID information used by KMS and X.

I would propose a file /etc/sysconfig/EDID with a syntax that links entries to some hardware path (graphics controller and port name). A tool to edit the configuration would be nice. A set of standard values, and the ability to fetch the EDID data from the currently attached screen. I could then connect a screen directly to the PC, grab the EDID data and save it to the config file and hook up the KVM switch again.


Additional info:

Comment 1 Matěj Cepl 2010-11-26 18:43:51 UTC

*** This bug has been marked as a duplicate of bug 582712 ***


Note You need to log in before you can comment on or make changes to this bug.