Bug 523916 - Restoration does not work in 0.7.1
Summary: Restoration does not work in 0.7.1
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libvirt
Version: unspecified
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-17 07:48 UTC by Daniel
Modified: 2010-03-16 17:23 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-15 16:08:51 UTC


Attachments (Terms of Use)
Log file of the guest when the restoration fails (639 bytes, text/x-log)
2009-09-17 07:48 UTC, Daniel
no flags Details
XML definition of the guest (1.34 KB, text/xml)
2009-09-17 07:49 UTC, Daniel
no flags Details
Libvirt daemon log in debug mode while saving and trying to restore the guest (143.65 KB, text/x-log)
2009-09-17 07:50 UTC, Daniel
no flags Details

Description Daniel 2009-09-17 07:48:57 UTC
Created attachment 361440 [details]
Log file of the guest when the restoration fails

Description of problem:

I'm having a problem with the latest libvirt (0.7.1). Restoration of a saved state doesn't seems to work.
I use the gzip compression, but have also tried other compressed format without success.
I also run my guests as root, as there's another problem with the saved file when running unprivileged.

I first run a virsh save command (my guest is called "xp"):

[root@virt ~] LANG=C_ALL virsh save xp /tmp/xp.state
Domain xp saved to /tmp/xp.state

The saved file seems correct:
ll -h /tmp/xp.state
rw------- 1 root root 36M sep 17 09:30 /tmp/xp.state

Then, I try to restore my guest from this file:

[root@virt ~] LANG=C_ALL virsh restore /tmp/xp.state
error: Failed to restore domain from /tmp/xp.state
error: internal error Timed out while reading monitor startup output

You'll find attached to this bug the XML definition of the guest, the log file /var/log/libvirt/qemu/xp.log when the restoration fails and the log of libvirt daemon in debug mode


Version-Release number of selected component (if applicable):

I'm running CentOS 5.3 x86_64 fully updated.

libvirt 0.7.1, recompiled from the srpm (http://libvirt.org/sources/libvirt-0.7.1-1.fc11.src.rpm) with the following argument:

rpmbuild --rebuild --without xen --without xen-proxy --without lxc --without vbox --without esx --without phyp --without one --without avahi --without openvz --without uml --without storage-mpath libvirt-0.7.1-1.fc11.src.rpm


qemu-kvm-0.10.6-1
kmod-kvm-2.6.30.1-2.el5
(from lfarkas repository)

How reproducible:
Always, I wasn't able to restore a guest from a saved state in 0.7.1

Steps to Reproduce:
1. save a guest state to a file using virsh save guest /file
2. try to restore the guest from the file using virsh restore /file
3.
  
Actual results:
The guest stay stoped

Expected results:
Guest restored

Additional info:
I have set Selinux to permissive, to be sure the problem is not related to it

Comment 1 Daniel 2009-09-17 07:49:38 UTC
Created attachment 361442 [details]
XML definition of the guest

Comment 2 Daniel 2009-09-17 07:50:26 UTC
Created attachment 361443 [details]
Libvirt daemon log in debug mode while saving and trying to restore the guest

Comment 3 Daniel 2009-10-15 16:08:51 UTC
This bugs seems corrected in libvirt 0.7.2 (I think it's this fix:
http://libvirt.org/git/?p=libvirt.git;a=commit;h=74b379cbd5ba9f472a3a2d5710e497966b1a3a37).


Note You need to log in before you can comment on or make changes to this bug.