Bug 523937 - Save on restored machine failed
Save on restored machine failed
Status: CLOSED DUPLICATE of bug 523939
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.4
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks: 523939
  Show dependency treegraph
 
Reported: 2009-09-17 05:50 EDT by Miroslav Rezanina
Modified: 2009-12-14 16:27 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 523939 (view as bug list)
Environment:
Last Closed: 2009-09-17 13:54:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xen deamon log (44.42 KB, text/plain)
2009-09-17 05:52 EDT, Miroslav Rezanina
no flags Details

  None (edit)
Description Miroslav Rezanina 2009-09-17 05:50:12 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.11) Gecko/2009060403 Red Hat/3.0.11-2.el5_3 Firefox/3.0.11

Enviroment:
===========
Host:
-----
RHEL 5.4 Server
kernel: 2.6.18-164.el5xen
xen: 3.0.3-94

Guest:
------
Paravirt Rawhide-20090915

Description of problem:
=======================
Running rawhide PV guest. Trying to save/restore guest. First try successfull, guest saved and restored again. When trying to save restored guest, error occurs:

error: POST operation failed: xend_post: error from xen daemon: (xend.err '/usr/lib64/xen/bin/xc_save 17 11 0 0 0 failed')


In virt-manager, guest status is "Shutoff". Using xm list shows guest in state shutdown.

Reproducible: Always

Steps to Reproduce:
1. Create guest
2. Save guest
3. Restore guest
4. Save guest - error
Actual Results:  
Error on second save

Expected Results:  
Save and restore possible more than once

With RHEL5 guest multiple Save & restore possible.

xend.log attached
Comment 1 Miroslav Rezanina 2009-09-17 05:52:56 EDT
Created attachment 361465 [details]
xen deamon log

Log after failed save
Comment 2 Mark McLoughlin 2009-09-17 08:24:55 EDT
Intersting. This looks like it might be a RHEL5.4 bug - if it turns out to be specific to Fedora 12, re-assign the bug to Fedora/kernel
Comment 3 Mark McLoughlin 2009-09-17 13:54:45 EDT

*** This bug has been marked as a duplicate of bug 523939 ***

Note You need to log in before you can comment on or make changes to this bug.