Bug 523949 - kernel 2.6.31-1[24].fc12 doesn't boot in xen PV guest
Summary: kernel 2.6.31-1[24].fc12 doesn't boot in xen PV guest
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.0
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Andrew Jones
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-17 11:16 UTC by Jiri Denemark
Modified: 2011-01-05 10:10 UTC (History)
13 users (show)

Fixed In Version: kernel-2.6.32-0.52.el6
Doc Type: Bug Fix
Doc Text:
Clone Of: 523941
Environment:
Last Closed: 2010-11-10 20:49:46 UTC


Attachments (Terms of Use)

Description Jiri Denemark 2009-09-17 11:16:31 UTC
+++ This bug was initially created as a clone of Bug #523941 +++

Description of problem:

When trying to install 32b Fedora as a PV guest under RHEL-5.4 Xen, the installation kernel hangs at the very beginning and doesn't even print a single line. However, 64b kernel works fine.

Version-Release number of selected component (if applicable):

Reproduced with 2.6.31-12 and 2.6.31.14

How reproducible:

100%

Steps to Reproduce:
1. virt-install --nographics --paravirt --name=f12-32 --ram=1500 --file=/var/lib/xen/images/virval/f12-32.img --file-size=4 --location=/mnt/download/fedora/linux/development/rawhide-20090916/i386/os
  
Actual results:

Nothing. Not a single line of message from the kernel.

Expected results:

Happily booting kernel.

Additional info:

Comment 2 RHEL Product and Program Management 2009-09-17 11:58:42 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Alexander Todorov 2009-10-01 12:37:28 UTC
I see similar stuff with 2.6.31-27.el6.x86_64 on a RHEL5.4 domO. The PV guest crashes before installation starts and xen logs do not reveal anything useful. 

This is with RHEL6.0-20090930.0. 

rawhide-20090930 is able to boot but it has kernel-2.6.31.1-48

xend.log says:
[2009-10-01 08:35:47 xend.XendDomainInfo 4999] ERROR (XendDomainInfo:2129) XendDomainInfo.destroy: xc.domain_destroy failed.
Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendDomainInfo.py", line 2125, in destroy
    xc.domain_pause(self.domid)
Error: (3, \047No such process\047)

Comment 4 Alexander Todorov 2009-10-01 12:40:52 UTC
More info:
/usr/lib64/xen/bin/xenctx -s System.map-2.6.31-27.el6.x86_64 4
xc_domain_pause: No such process

Comment 5 Alexander Todorov 2009-10-01 13:07:03 UTC
FYI: this setup dom0/domU works fine with KVM.

Comment 6 Andrew Jones 2009-10-01 13:09:39 UTC
I suggest we add this kernel to the boot partition and grub.conf of a working
image. And add console=hvc0 earlyprintk=xen to kernel command line. Then try to
boot it with virsh create. Hopefully we'll see something.

Comment 7 Andrew Jones 2009-10-01 13:21:53 UTC
Ah wait a moment, Alexander you must be see in a different problem. You say you're trying to boot  2.6.31-27.el6.x86_64, but this bug is for 32-bit DomU on 64-bit Dom0. You'll need to open a new bug describing exactly what you're trying to install.

Comment 8 Alexander Todorov 2009-10-01 15:01:54 UTC
I've tried i386 PV guest but hit bug #526730. After this is fixed I can know if I'm seeing a separate issue or not.

Comment 11 Paolo Bonzini 2010-02-23 17:49:15 UTC
Andrew, this was a bit more confusing so I'm hesitant to close it myself.  However, the rebase of the RHEL6 kernel to 2.6.32 should have brought in all the fixes, in particular

33df4db04a79660150e1948e3296eeb451ac121b  x86: xen, i386: reserve Xen pagetables
d560bc61575efae43595cbcb56d0ba3b9450139c  x86, xen: Suppress WP test on Xen

Right?

Comment 12 Andrew Jones 2010-02-23 18:20:55 UTC
Yeah, this one was ugly. And another commit needed is 

33b6563da26335fbe6834b743ddd00fa8f7ab09a

The Fedora BZ that this BZ is cloned off was never closed, since it was never clear that a boot problem caused by a patch that set up slab allocators earlier in the boot sequence was truly fixed, or if it was only masked. We've had a lot of run time on F12 now though since it was released months ago. I think we're safe to close that BZ and set this one to modified. All 3 needed commits are already in RHEL6.

Comment 17 releng-rhel@redhat.com 2010-11-10 20:49:46 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.