Bug 523973 - Dist-Upgrade F10->F11 breaks bind
Summary: Dist-Upgrade F10->F11 breaks bind
Keywords:
Status: CLOSED DUPLICATE of bug 510290
Alias: None
Product: Fedora
Classification: Fedora
Component: dnssec-conf
Version: 11
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Paul Wouters
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-17 12:58 UTC by Harald Reindl
Modified: 2009-09-19 15:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-19 15:13:33 UTC
Type: ---


Attachments (Terms of Use)

Description Harald Reindl 2009-09-17 12:58:47 UTC
Why in the world does a dist-upgrade via yum touch my named.conf and try to add 3 dnssec-lines? 

named.conf has NEVER to be touched by any update, there are .rpmnew-files and in worstcase .rpmsave but do not try to change existing configurations you do not know

this change results in a invalid syntax becuaso it is set in my allow-recursion{} section instead before oder after, so bind is dead after that

happened on two machines



  195.206.96.89;
  195.206.96.90;
 dnssec-enable yes;
 dnssec-validation yes;
 dnssec-lookaside . trust-anchor dlv.isc.org.;
};
};

Comment 1 Gene Czarcinski 2009-09-18 18:52:16 UTC
This report is a dup of https://bugzilla.redhat.com/show_bug.cgi?id=510290

I agree that named.conf should not be modified by software ... this is a "user" defined configuration file.  BUT, if it is modified, then the modification should WORK!  It currently does not.

Yes, it works for simplistic cases but does not handle the actual free-form officially allowed for named.conf.  Specifically, it does not parse "options" correctly.  If the left-brace after options is on a separate line, it screws up.  If (as in my case) I use multiple physical lines for lists of ip-numbers with "};" on a separate line, it screws up.

Yes, you can edit named.conf so the problem will not occur but this should not be necessary.

Comment 2 Gene Czarcinski 2009-09-19 15:13:33 UTC
I am marking this as a dup so that there is only one report thread to follow.  See that bug report for additional information.

*** This bug has been marked as a duplicate of bug 510290 ***


Note You need to log in before you can comment on or make changes to this bug.