Bug 523998 - Make LAM conform to guidelines or remove it from Fedora
Make LAM conform to guidelines or remove it from Fedora
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lam (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Doug Ledford
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-17 10:44 EDT by Susi Lehtola
Modified: 2014-01-21 18:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-19 18:14:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Susi Lehtola 2009-09-17 10:44:33 EDT
The packaging of lam must be made to conform to the environment modules & MPI guidelines which have been approved by FESCo a month ago.
http://www.fedoraproject.org/wiki/PackagingDrafts/MPI
http://www.fedoraproject.org/wiki/PackagingDrafts/EnvironmentModules

http://meetbot.fedoraproject.org/fedora-meeting/2009-08-14/fedora-meeting.2009-08-14-17.01.html
Comment 1 Doug Ledford 2009-09-23 12:41:25 EDT
I'd rather just see lam deprecated or removed.  It's very obsolete.
Comment 2 Susi Lehtola 2009-09-23 12:54:04 EDT
That's an option too, remove it from F12 altogether..?
Comment 3 Susi Lehtola 2009-10-17 04:54:01 EDT
ping?
Comment 4 Doug Ledford 2009-10-20 14:27:57 EDT
I'm not sure how to go about removing a package (although I think in Fedora parlance it's never *really* removed, just deprecated and removed from comps...you can still get to it via yum install from older repos or something like that).  But, I think that's what needs done here.
Comment 5 Bill Nottingham 2009-10-20 16:05:54 EDT
Done.
Comment 6 Susi Lehtola 2009-10-20 16:12:41 EDT
Actually, I think you should follow

http://fedoraproject.org/wiki/PackageMaintainers/PackageEndOfLife

This package has been obsolete for a long time and should be retired altogether from new distributions. Moreover, it has been obsoleted by openmpi long ago, so the openmpi packages should obsolete lam on the distribution that doesn't have lam anymore.
Comment 7 Bill Nottingham 2009-10-20 23:05:26 EDT
Doing that would not be a comps change... reassigning.
Comment 8 Doug Ledford 2009-10-25 19:31:13 EDT
I've done everything except the comps change and the blacklist from repos change, and I've file the ticket with rel-eng to do those things.
Comment 9 Bug Zapper 2009-11-16 07:33:59 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Susi Lehtola 2009-11-26 10:52:02 EST
Okay, as F-12 has gone gold, now it is possible to remove lam from rawhide. Please write a statement about the obsoletion to fedora-devel.

Maybe you could ask in the same message if someone is still interested enough in LAM to take ownership and clean up the package to conform to the MPI guidelines. (This only needs to be done for F-12. [Maybe F-11 too..?])
Comment 11 Susi Lehtola 2009-12-08 02:59:06 EST
I sent a mail about the possible deprecation of lam on fedora-devel at
 http://www.linux-archive.org/fedora-development/291913-deprecation-lam-mpi.html

As a reply to this I got a mail from Jeff Squyres (a faculty member of the team according to http://www.lam-mpi.org/about/devel/) asking us to finally pull the plug on LAM/MPI.

Could we move forward with this?
Comment 12 Doug Ledford 2009-12-08 10:05:55 EST
Thanks Jussi.  I've known Jeff for a long time, and yes he was part of the LAM devel crew and is now a primary part of the Open MPI crew.  If he agrees that we pull it, then I'm 1000% in agreement.

So, checking CVS I see that it's still got a dead_package file in both devel and F-12.  That just leaves re-creating the trac ticket to block the package from rawhide (it doesn't make sense to block if from F12 at this point).
Comment 13 Susi Lehtola 2009-12-08 10:12:11 EST
OK, just be sure to holler on fedora-devel about the removal some time before actually requesting the pullout.
Comment 14 Doug Ledford 2009-12-08 10:44:52 EST
Both are already done.
Comment 15 Doug Ledford 2010-02-19 16:39:35 EST
Trac ticket filed requesting removal from f13 and rawhide since it's been about 2 months now since I email f-d about the change.
Comment 16 Doug Ledford 2010-02-19 16:40:08 EST
f-rel-eng trac ticket #3424
Comment 17 Doug Ledford 2010-02-19 18:14:10 EST
Blocked.

Note You need to log in before you can comment on or make changes to this bug.