Bug 524 - vacuum cleaner script
Summary: vacuum cleaner script
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: postgresql (Show other bugs)
(Show other bugs)
Version: 5.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-12-18 23:20 UTC by borgia
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-12-30 04:07:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description borgia 1998-12-18 23:20:52 UTC
a postgres-vacuum script in /etc/cron.weekly is recommended:

-cut-
#!/bin/bash

su postgres -c "for database in /var/lib/pgsql/base/* ; do
psql -c "vacuum" -d \${database##/var/lib/pgsql/base/} -q ;
done"
exit 0
-cut-

[!!!reported for RH 5.0!!!]

Comment 1 David Lawrence 1998-12-23 15:49:59 UTC
This is a suggestion for a product improvement.

Comment 2 Cristian Gafton 1998-12-30 04:07:59 UTC
Doing a vacuum on the databases is a action that only the DBA
administrator should decide on. We can not set things to arbitrarily
clean the transaction logs from the database. Due to the high risk of
destroying extremely valuable data, we will not change.


Note You need to log in before you can comment on or make changes to this bug.