Bug 524012 - libvirt cannot hot-unplug devices which were not previously hot-plugged
libvirt cannot hot-unplug devices which were not previously hot-plugged
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
12
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks: F13VirtTarget
  Show dependency treegraph
 
Reported: 2009-09-17 11:20 EDT by Mark McLoughlin
Modified: 2010-03-16 11:23 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-16 11:23:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2009-09-17 11:20:57 EDT
The problem is here:

  if (!virHostdevHasValidGuestAddr(detach)) {
      qemudReportError(conn, NULL, NULL, VIR_ERR_OPERATION_FAILED,
                       "%s", _("hostdev cannot be detached - device state missing"));
      return -1;
  }

Basically, because we do not know what PCI address was assigned to the device at startup, we cannot remove it.

This will be fixed with future versions of qemu and libvirt by libvirt parsing the output of a monitor command to query the PCI address.

Adding to F13VirtTarget
Comment 1 Bug Zapper 2009-11-16 07:34:07 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Cole Robinson 2010-03-16 11:23:03 EDT
Pretty sure this is fixed in latest libvirt. Since this is part of -device support which is hugely invasive, it will only be in rawhide/F14 unless we rebase older Fedora. Closing as RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.