Bug 524018 - FirstAid Kit selection menu in F12 Alpha rescue on serial console difficult to use
Summary: FirstAid Kit selection menu in F12 Alpha rescue on serial console difficult t...
Keywords:
Status: CLOSED DUPLICATE of bug 519442
Alias: None
Product: Fedora
Classification: Fedora
Component: firstaidkit
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Martin Sivák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 494832
TreeView+ depends on / blocked
 
Reported: 2009-09-17 15:52 UTC by Patrick C. F. Ernzer
Modified: 2009-09-17 16:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-17 16:00:28 UTC


Attachments (Terms of Use)

Description Patrick C. F. Ernzer 2009-09-17 15:52:32 UTC
Description of problem:
FirstAid Kit selection menu in F12 Alpha rescue on serial console difficult to use

Version-Release number of selected component (if applicable):
Fedora 12 Alpha


How reproducible:
always

Steps to Reproduce:
1. have a machine with only serial console (no VGA on the board)
   console=ttyS0,115200 or console=ttyS0,38400 (as applicable)
2. Boot F12 Alpha rescue mode
3. answer all questions up to the point of getting the 'chroot to /mnt/sysimage' dialog
  
Actual results:
a new dialog from FirstAid-Kit appears but it is near impossible to navigate on serial console.

All previous dialogs had nice text boxes (continuous lines around them, block cursor showing currently selected item)

First Aid Kit quickstart menu on the other hand is old style WRT the box drawing, meaning the box is made up of minus and pipe symbols (minor but as it was possible to draw continuous lines for previous boxes, FAK should do the same).

Much more annoying, cursor blinks on < OK > and does not show what selection in the list is currently active.

Expected results:
Expectation was that I hit Tab, my block cursor goes to the list, I move with arrows until I have selected what I need, Tab back or just enter at this point. Basically same navigation as for all previous dialogs.

Additional info:
While there is 0 visual feedback, it seems that some navigation does take place, but it's driving in the dark as one does not see at all what was selected. example; hit down arrow an arbitrary number of times, now hit Enter.

Comment 1 Martin Sivák 2009-09-17 16:00:28 UTC

*** This bug has been marked as a duplicate of bug 519442 ***


Note You need to log in before you can comment on or make changes to this bug.