Bug 524024 - setroubleshoot: SELinux is preventing polkitd (policykit_t) "read" var_lib_t.
setroubleshoot: SELinux is preventing polkitd (policykit_t) "read" var_l...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: polkit (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:412bf8e2148...
:
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-09-17 12:09 EDT by John Poelstra
Modified: 2009-09-25 12:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-25 12:24:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Poelstra 2009-09-17 12:09:48 EDT
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing polkitd (policykit_t) "read" var_lib_t.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by polkitd. It is not expected that this access
is required by polkitd and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Additional Information:

Source Context                system_u:system_r:policykit_t:s0-s0:c0.c1023
Target Context                system_u:object_r:var_lib_t:s0
Target Objects                10-desktop-policy.pkla [ file ]
Source                        polkitd
Source Path                   /usr/libexec/polkit-1/polkitd (deleted)
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.26-8.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.31-0.125.4.2.rc5.git2.fc12.x86_64 #1 SMP Tue
                              Aug 11 21:00:45 EDT 2009 x86_64 x86_64
Alert Count                   26
First Seen                    Thu 17 Sep 2009 08:29:14 AM PDT
Last Seen                     Thu 17 Sep 2009 08:53:06 AM PDT
Local ID                      bc652b23-0ed7-40a2-abce-522a770322c7
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1253202786.182:77): avc:  denied  { read } for  pid=1229 comm="polkitd" name="10-desktop-policy.pkla" dev=dm-1 ino=143383 scontext=system_u:system_r:policykit_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_lib_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1253202786.182:77): avc:  denied  { open } for  pid=1229 comm="polkitd" name="10-desktop-policy.pkla" dev=dm-1 ino=143383 scontext=system_u:system_r:policykit_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_lib_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1253202786.182:77): arch=c000003e syscall=2 success=yes exit=7 a0=233df60 a1=0 a2=0 a3=0 items=0 ppid=1 pid=1229 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="polkitd" exe=2F7573722F6C6962657865632F706F6C6B69742D312F706F6C6B697464202864656C6574656429 subj=system_u:system_r:policykit_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= policykit_t ==============
allow policykit_t var_lib_t:file { read open };
Comment 1 Daniel Walsh 2009-09-17 15:58:15 EDT
Whare is 10-desktop-policy.pkla?

Please update to the latest policy.
Comment 2 Matthias Clasen 2009-09-25 11:33:08 EDT
To answer that question, it is in /var/lib/polkit-1/localauthority/10-vendor.d

Dan, is this fixed in the latest policy ?
Comment 3 Daniel Walsh 2009-09-25 12:24:48 EDT
Looks like a labeling issue that should be fixed in the latest policy

# ls -lZ /var/lib/polkit-1/localauthority/
drwxr-xr-x. root root system_u:object_r:policykit_var_lib_t:s0 10-vendor.d
drwxr-xr-x. root root system_u:object_r:policykit_var_lib_t:s0 20-org.d
drwxr-xr-x. root root system_u:object_r:policykit_var_lib_t:s0 30-site.d
drwxr-xr-x. root root system_u:object_r:policykit_var_lib_t:s0 50-local.d
drwxr-xr-x. root root system_u:object_r:policykit_var_lib_t:s0 90-mandatory.d

Note You need to log in before you can comment on or make changes to this bug.