Bug 52403 - exportfs -u doesn't work
Summary: exportfs -u doesn't work
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-23 15:55 UTC by Marty Shannon
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-19 15:57:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marty Shannon 2001-08-23 15:55:16 UTC
Description of Problem:
exportfs -u fails to unexport a previously exported filesystem

Version-Release number of selected component (if applicable):
0.3.1-12

How Reproducible:
100%

Steps to Reproduce:
1. add "/mnt/cdrom *" to /etc/exports
2. exportfs -a
3. on client, "mount server:/mnt/cdrom /mnt/s-cdrom"
4. on client, "du /mnt/s-cdrom"
5. on client, "umount /mnt/s-cdrom"
6. on server, "exportfs -u client:/home/test"
7. on server, "umount /mnt/cdrom"

Actual Results:
step 7 fails because step 6 actually failed to remove the entry from the
kernel's table, so the kernel still has (presumably the root inode) still
open, preventing the umount from succeeding

Expected Results:
step 7 should succeed, because step 6 should tell the kernel to let go

Additional Information:
If (after step 7) you comment out the line added in step 1, then execute
"exportfs -r", re-executing step 7 works as expected, so there is something
 done correctly by the "-r" path that is not being done in the "-u" path.

Comment 1 Bob Matthews 2001-08-23 19:04:43 UTC
It appears as if mountd is honoring UMOUNT requests from clients, but not
notifying the server's kernel that the exported directory is no longer in use. 
This is also reflected in /var/lib/nfs/rmtab, which is supposed to list those
file systems which mountd currently thinks are mounted by clients.

Your workaround ("exportfs -r") must force rpc.mountd to rebuild it's list and
notify the kernel.

I will notify the nfs-utils maintainers.

Comment 2 Glen Foster 2001-08-24 17:08:34 UTC
This defect is considered SHOULD-FIX for Fairfax.

Comment 3 Pete Zaitcev 2004-04-19 15:57:06 UTC
The bug fell over the horizon due to manpower constraints, closing.
If Fedora still fails to unexport, please refile.



Note You need to log in before you can comment on or make changes to this bug.