Bug 524030 - setroubleshoot: SELinux is preventing rtkit-daemon "setcap" access.
Summary: setroubleshoot: SELinux is preventing rtkit-daemon "setcap" access.
Keywords:
Status: CLOSED DUPLICATE of bug 524026
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:d62332728cd...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-17 16:20 UTC by David
Modified: 2009-09-17 20:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-17 20:01:41 UTC


Attachments (Terms of Use)

Description David 2009-09-17 16:20:46 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing rtkit-daemon "setcap" access.

Detailed Description:

SELinux denied access requested by rtkit-daemon. It is not expected that this
access is required by rtkit-daemon and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:initrc_t:s0-s0:c0.c1023
Target Context                system_u:system_r:initrc_t:s0-s0:c0.c1023
Target Objects                None [ process ]
Source                        rtkit-daemon
Source Path                   rtkit-daemon
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-1.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux chewbacca.headquarters.integrinautics.com
                              2.6.31-23.fc12.i686.PAE #1 SMP Wed Sep 16 15:53:47
                              EDT 2009 i686 i686
Alert Count                   1
First Seen                    Thu 17 Sep 2009 09:17:00 AM PDT
Last Seen                     Thu 17 Sep 2009 09:17:00 AM PDT
Local ID                      73b765dc-9212-4281-92d6-dbb650f49470
Line Numbers                  

Raw Audit Messages            

node=chewbacca.headquarters.integrinautics.com type=AVC msg=audit(1253204220.131:48): avc:  denied  { setcap } for  pid=1519 comm="rtkit-daemon" scontext=system_u:system_r:initrc_t:s0-s0:c0.c1023 tcontext=system_u:system_r:initrc_t:s0-s0:c0.c1023 tclass=process


audit2allow suggests:

#============= initrc_t ==============
allow initrc_t self:process setcap;

Comment 1 Daniel Walsh 2009-09-17 20:01:41 UTC

*** This bug has been marked as a duplicate of bug 524026 ***


Note You need to log in before you can comment on or make changes to this bug.