Bug 524042 - ftrace faulted on writing [<f7e487af>] i2c_new_dummy+0x8/0x59 [i2c_core]
Summary: ftrace faulted on writing [<f7e487af>] i2c_new_dummy+0x8/0x59 [i2c_core]
Keywords:
Status: CLOSED DUPLICATE of bug 523635
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-17 16:55 UTC by Jóhann B. Guðmundsson
Modified: 2009-09-27 11:04 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-27 11:04:18 UTC


Attachments (Terms of Use)
Dmesg ... (35.64 KB, text/plain)
2009-09-17 16:55 UTC, Jóhann B. Guðmundsson
no flags Details

Description Jóhann B. Guðmundsson 2009-09-17 16:55:16 UTC
Created attachment 361526 [details]
Dmesg ... 

Description of problem:

Notice this in dmesg better to report-it.. 

usb 3-1: new full speed USB device using uhci_hcd and address 2
------------[ cut here ]------------
WARNING: at kernel/trace/ftrace.c:1003 ftrace_bug+0x15c/0x225() (Not tainted)
Hardware name: Inspiron 6000
Modules linked in: i2c_core(+)
Pid: 74, comm: modprobe Not tainted 2.6.31-23.fc12.i686.PAE #1
Call Trace:
 [<c044c285>] warn_slowpath_common+0x7b/0xa3
 [<c04aaf4f>] ? ftrace_bug+0x15c/0x225
 [<f7e487af>] ? i2c_new_dummy+0x8/0x59 [i2c_core]
 [<c044c2ce>] warn_slowpath_null+0x21/0x35
 [<c04aaf4f>] ftrace_bug+0x15c/0x225
 [<c04abe37>] ftrace_convert_nops+0x198/0x236
 [<f7e487af>] ? i2c_new_dummy+0x8/0x59 [i2c_core]
 [<c04abf16>] ftrace_module_notify+0x41/0x6e
 [<c083e31f>] notifier_call_chain+0x5d/0x95
 [<c0469f89>] __blocking_notifier_call_chain+0x52/0x78
 [<c0469fd0>] blocking_notifier_call_chain+0x21/0x37
 [<c0483833>] sys_init_module+0xa1/0x1fe
 [<c04099cb>] sysenter_do_call+0x12/0x38
---[ end trace 160151ee1f24b6b9 ]---
ftrace faulted on writing [<f7e487af>] i2c_new_dummy+0x8/0x59 [i2c_core]
[drm] Initialized drm 1.1.0 20060810

Version-Release number of selected component (if applicable):

2.6.31-23.fc12.i686.PAE

How reproducible:


Steps to Reproduce:
1. 
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Han Pingtian 2009-09-21 02:20:25 UTC
Similar messages come from /var/log/messages with 2.6.31-33.fc12.x86_64:

Sep 21 10:14:01 dhcp-65-9 kernel: ------------[ cut here ]------------
Sep 21 10:14:01 dhcp-65-9 kernel: WARNING: at kernel/trace/ftrace.c:1003 ftrace_bug+0x198/0x27e() (Not tainted)
Sep 21 10:14:01 dhcp-65-9 kernel: Hardware name: OptiPlex 740 Enhanced
Sep 21 10:14:01 dhcp-65-9 kernel: Modules linked in: i2c_core(+)
Sep 21 10:14:01 dhcp-65-9 kernel: Pid: 89, comm: modprobe Not tainted 2.6.31-33.fc12.x86_64 #1
Sep 21 10:14:01 dhcp-65-9 kernel: Call Trace:
Sep 21 10:14:01 dhcp-65-9 kernel: [<ffffffff810642ec>] warn_slowpath_common+0x95/0xc3
Sep 21 10:14:01 dhcp-65-9 kernel: [<ffffffffa0003072>] ? i2c_new_dummy+0x8/0x5e [i2c_core]
Sep 21 10:14:01 dhcp-65-9 kernel: [<ffffffff81064341>] warn_slowpath_null+0x27/0x3d
Sep 21 10:14:01 dhcp-65-9 kernel: [<ffffffff810d4ace>] ftrace_bug+0x198/0x27e
Sep 21 10:14:01 dhcp-65-9 kernel: [<ffffffffa0003072>] ? i2c_new_dummy+0x8/0x5e [i2c_core]
Sep 21 10:14:01 dhcp-65-9 kernel: [<ffffffff810d5d26>] ftrace_convert_nops+0x201/0x2b9
Sep 21 10:14:01 dhcp-65-9 kernel: [<ffffffffa0003072>] ? i2c_new_dummy+0x8/0x5e [i2c_core]
Sep 21 10:14:01 dhcp-65-9 kernel: [<ffffffff810d5e2a>] ftrace_module_notify+0x4c/0x7f
Sep 21 10:14:01 dhcp-65-9 kernel: [<ffffffff81509c65>] notifier_call_chain+0x72/0xba
Sep 21 10:14:01 dhcp-65-9 kernel: [<ffffffff81086e71>] ? __blocking_notifier_call_chain+0x4c/0x8e
Sep 21 10:14:01 dhcp-65-9 kernel: [<ffffffff81086e88>] __blocking_notifier_call_chain+0x63/0x8e
Sep 21 10:14:01 dhcp-65-9 kernel: [<ffffffff81086eda>] blocking_notifier_call_chain+0x27/0x3d
Sep 21 10:14:01 dhcp-65-9 kernel: [<ffffffff810a472a>] sys_init_module+0xb7/0x249
Sep 21 10:14:01 dhcp-65-9 kernel: [<ffffffff81011f42>] system_call_fastpath+0x16/0x1b
Sep 21 10:14:01 dhcp-65-9 kernel: ---[ end trace e826f98e2f432b5c ]---

Comment 2 Chuck Ebbert 2009-09-23 11:10:21 UTC
This is caused by the modules-ro-nx patch:

http://lkml.org/lkml/2009/9/21/362

Comment 3 Chuck Ebbert 2009-09-24 16:22:31 UTC
Should be fixed in 2.6.31-40

Comment 4 Michal Jaegermann 2009-09-26 00:49:11 UTC
> Should be fixed in 2.6.31-40

I am afraid that this is not the case:
.....
udev: starting version 145
------------[ cut here ]------------
WARNING: at kernel/trace/ftrace.c:1003 ftrace_bug+0x198/0x27e() (Not tainted)
Hardware name: To Be Filled By O.E.M.
Modules linked in: i2c_core(+)
Pid: 81, comm: modprobe Not tainted 2.6.31-40.fc12.x86_64 #1
Call Trace:
 [<ffffffff810642ec>] warn_slowpath_common+0x95/0xc3
 [<ffffffffa0003072>] ? i2c_new_dummy+0x8/0x5e [i2c_core]
 [<ffffffff81064341>] warn_slowpath_null+0x27/0x3d
 [<ffffffff810d4ace>] ftrace_bug+0x198/0x27e
 [<ffffffffa0003072>] ? i2c_new_dummy+0x8/0x5e [i2c_core]
 [<ffffffff810d5d26>] ftrace_convert_nops+0x201/0x2b9
 [<ffffffffa0003072>] ? i2c_new_dummy+0x8/0x5e [i2c_core]
 [<ffffffff810d5e2a>] ftrace_module_notify+0x4c/0x7f
 [<ffffffff81509c65>] notifier_call_chain+0x72/0xba
 [<ffffffff81086e71>] ? __blocking_notifier_call_chain+0x4c/0x8e
 [<ffffffff81086e88>] __blocking_notifier_call_chain+0x63/0x8e
 [<ffffffff81086eda>] blocking_notifier_call_chain+0x27/0x3d
 [<ffffffff810a472a>] sys_init_module+0xb7/0x249
 [<ffffffff81011f42>] system_call_fastpath+0x16/0x1b
---[ end trace aa747a3466ca487c ]---
ftrace faulted on writing [<ffffffffa0003072>] i2c_new_dummy+0x8/0x5e [i2c_core]
.......

Comment 5 Michal Jaegermann 2009-09-26 00:55:29 UTC
BTW - this looks like a duplicate of bug #523635.

Comment 6 Chuck Ebbert 2009-09-27 11:04:18 UTC

*** This bug has been marked as a duplicate of bug 523635 ***


Note You need to log in before you can comment on or make changes to this bug.