Bug 524055 - [RHEL6 Xen]: Boot hang when installing HVM DomU
[RHEL6 Xen]: Boot hang when installing HVM DomU
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Andrew Jones
Martin Jenner
:
Depends On: 524052
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-17 13:44 EDT by Andrew Jones
Modified: 2011-01-05 05:10 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 524052
Environment:
Last Closed: 2010-02-23 11:06:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Jones 2009-09-17 13:44:13 EDT
+++ This bug was initially created as a clone of Bug #524052 +++

Description of problem:

Attempted to boot a fully virtualized DomU with rawhide's 2.6.31-14.fc12.x86_64 for installation hangs almost immediately.

How reproducible:

100%

Steps to Reproduce:

virt-install \
	--hvm \
	--name=rawhide \
	--ram=2048 \
	--file=/vm/rawhide.img \
	--file-size=8 \
	--location=/mnt/download/fedora/linux/development/x86_64/os

Select install from the boot menu
  
Actual results:

Hangs after printing the following

Loading vmlinuz............
Loading initrd.img................
Probing EDD (edd=off to disable)... ok

Expected results:

boots

Additional info:

There are no logs in xm dmesg

Note, a 32-bit HVM boots and installs on a 32-bit host

--- Additional comment from drjones@redhat.com on 2009-09-17 13:36:35 EDT ---

Moving to kernel-xen for now since a 64-bit HVM rawhide boots past this point on an upstream Xen host.
Comment 2 RHEL Product and Program Management 2009-09-17 14:27:40 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Andrew Jones 2009-09-29 15:04:40 EDT
Ok, I've bisected this down on the upstream kernel to a patch that enables xsave,

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=dc1e35c6e95e8923cf1d3510438b63c600fee1e2

Overriding that capability as "not supported" allows the HVM guest to boot.

I'm looking at how to deal with it now.  There's been some discussion of it in upstream Xen, but nothing too conclusive as far as I can tell.

Masking this capability from the guest might be the best option.
Comment 4 Andrew Jones 2009-10-07 04:49:47 EDT
This bug will probably be closed as not a bug, since the problem is best solved in the hypervisor, see bug 524052. Regarding the 32-bit HVM booting that was stated in comment 1. That was reported from a different machine, probably one not supporting xsave. On my machine 32-on-32 fails the same way as with 64b.

Also note: if you need to boot f12/RHEL6 on a hypervisor that doesn't mask XSAVE you can still do it by adding noxsave to the kernel command line.
Comment 5 Paolo Bonzini 2010-02-23 11:06:50 EST
Installing a RHEL6 guest on a RHEL5.4 hypervisor will most likely fail on relatively recent hardware.  This is because RHEL5.4 does not hide new hardware features that are supported by the 2.6.32 kernel but not by the hypervisor.  RHEL5.5 fixed this.

Should we require release notes for this, or should we just close it as NOTABUG?
Comment 6 Bill Burns 2010-02-23 13:13:33 EST
Well it is correct to close this as not a bug as it is not a RHEL 6 issue. But the question remains if we should be z-streaming the RHEL 5.5 fix for 5.4.z
and RHEV too.

Note You need to log in before you can comment on or make changes to this bug.