Bug 524086 - F12 - creating a new VM with an ISO as the source media fails
F12 - creating a new VM with an ISO as the source media fails
Status: CLOSED DUPLICATE of bug 517379
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-09-17 15:58 EDT by Joel
Modified: 2009-09-21 12:04 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-09-21 12:04:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
/var/log/libvirt/qemu/RHEL5.log from failed attempt to create the new VM (1.20 KB, application/octet-stream)
2009-09-17 15:59 EDT, Joel
no flags Details

  None (edit)
Description Joel 2009-09-17 15:58:16 EDT
Description of problem:
After filling out the information for a new VM to create (using an ISO as the source media), the creation process fails.

Version-Release number of selected component (if applicable):

How reproducible:
Every single time

Steps to Reproduce:
1.Launch virt-manager, and start creating a new VM
2.Use an ISO on the local file system as the source media.
3.Click "Finish" to start the creation of the VM.
Actual results:
virt-manager spits out:

Unable to complete install '<class 'libvirt.libvirtError'> internal error unable to start guest: qemu: could not open disk image /root/RHEL5.4-Server-20090819.0-x86_64-DVD.iso

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 1489, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 628, in start_install
    return self._do_install(consolecb, meter, removeOld, wait)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 726, in _do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 1077, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: internal error unable to start guest: qemu: could not open disk image /root/RHEL5.4-Server-20090819.0-x86_64-DVD.iso

Expected results:
No error message.  A new window showing the initial boot process.

Additional info:
Tried this with a SLES11 ISO and it fails just the same.
Comment 1 Joel 2009-09-17 15:59:48 EDT
Created attachment 361558 [details]
/var/log/libvirt/qemu/RHEL5.log from failed attempt to create the new VM
Comment 2 Joel 2009-09-17 16:27:37 EDT
Also, manually running:

LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin /usr/bin/qemu-kvm -M pc-0.11 -m 256 -smp 1 -name RHEL5 -uuid 56b0a7d8-8bda-3f01-e3b6-c6d939316b1a -monitor unix:/var/lib/libvirt/qemu/RHEL5.monitor,server,nowait -no-reboot -boot d -drive file=/var/lib/libvirt/images/RHEL5.img,if=ide,index=0,format=raw -drive file=/root/RHEL5.4-Server-20090819.0-x86_64-DVD.iso,if=ide,media=cdrom,index=2 -net nic,macaddr=52:54:00:63:b7:81,vlan=0,name=nic.0 -net tap,fd=18,vlan=0,name=tap.0 -serial pty -parallel none -usb -vga cirrus

(I only removed the '-S' and '-vnc' options) works from the command line.
Comment 3 Joel 2009-09-17 16:32:24 EDT
And more poking around reveals that moving the ISO out from '/root/' to '/' now makes the error message go away.
Comment 4 Mark McLoughlin 2009-09-21 12:04:33 EDT
Thanks Joel

qemu now runs as the 'qemu' user, so it need access to the images - so, e.g. doing 'chmod o+x /root/' would have fixed it too

bug #517379 describes how we should have better error messages for this case

*** This bug has been marked as a duplicate of bug 517379 ***

Note You need to log in before you can comment on or make changes to this bug.