Bug 524101 - Pushing 2 different packages of the same NVREA to 2 different channels results in the same package in both
Summary: Pushing 2 different packages of the same NVREA to 2 different channels resul...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Server
Version: 0.5
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Justin Sherrill
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space08
TreeView+ depends on / blocked
 
Reported: 2009-09-17 21:01 UTC by Justin Sherrill
Modified: 2010-02-16 12:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-14 16:13:34 UTC


Attachments (Terms of Use)

Description Justin Sherrill 2009-09-17 21:01:45 UTC
1.  find 2 packages of the same NVREA (i.e.  foo-1.0-1.i386)
2.  Create 2 channels
3.  Push the first package to the first channel
4.  Push the second package to the 2nd channel

expected results:

each channel has a different package

actual results:

both packages are pushed, but the same package is pushed to both channels.  Looks like whichever one is pushed first.

Comment 1 Jeremy Mueller 2009-11-10 22:19:36 UTC
This is a big issue if you push both RHEL and CentOS packages to the same Spacewalk server.  In our case, the packages are pushed in the order that the distros release them, so the RHEL packages end up being put in the CentOS channels instead of the CentOS packages.

Also, I think that bug 530446 is a duplicate of this bug.

Comment 2 Justin Sherrill 2009-12-14 16:13:34 UTC
So this should be fixed in 0.7 with prad's commit here:

614a497d6053968a6e30d35c02bbd84a1dfd74d7


I'm going to go ahead and close, but if anyone is still hitting this, let me know.

-Justin

Comment 3 Michael Mráka 2010-02-16 12:59:16 UTC
Spacewalk 0.8 has been released


Note You need to log in before you can comment on or make changes to this bug.