This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 524117 - virt-manager: Error installing guests - can't mount the / filesystem after the install process is finished
virt-manager: Error installing guests - can't mount the / filesystem after th...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-17 18:13 EDT by Lucas Meneghel Rodrigues
Modified: 2015-10-18 18:41 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-16 13:50:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot of the install failure (396.67 KB, image/png)
2009-09-17 18:14 EDT, Lucas Meneghel Rodrigues
no flags Details

  None (edit)
Description Lucas Meneghel Rodrigues 2009-09-17 18:13:21 EDT
Description of problem: When trying to install an operating system using virt-manager, an error happens at the end of the install process. Taking Fedora 11 as the example operating system, anaconda throws the following error:

An error occurred mounting device /dev/mapper/vg_f11-lv_root as /: mount failed: (2, None). This is a fatal error and the install cannot continue.

Version-Release number of selected component (if applicable):

Virt-manager version:

virt-manager-0.8.0-3.fc12.noarch

Other relevant package versions:

libvirt-python-0.7.1-1.fc12.i686
libvirt-client-0.7.1-1.fc12.i686
libvirt-0.7.1-1.fc12.i686
qemu-img-0.10.92-4.fc12.i686
qemu-kvm-0.10.92-4.fc12.i686
qemu-common-0.10.92-4.fc12.i686
gpxe-roms-qemu-0.9.7-5.fc12.noarch
qemu-system-x86-0.10.92-4.fc12.i686


How reproducible: Allways


Steps to Reproduce:
1. Install Fedora 11 GA (livecd) using virt-manager 
2. Wait until the install finishes
3. In the final stage of install, the error:

An error occurred mounting device /dev/mapper/vg_f11-lv_root as /: mount failed: (2, None). This is a fatal error and the install cannot continue.

(screenshot attached)


Actual results: Install fails.


Expected results: Fedora 11 install inside the VM succeeds.


Additional info:

Checking the permissions of the image file created by virt-manager one can see:

[f12@f12 images]$ ls -la
total 3716888
drwxrwxr-x. 2 f12  f12        4096 2009-09-17 18:41 .
drwxrwxr-x. 3 f12  f12        4096 2009-09-17 12:45 ..
-rw-------. 1 qemu qemu 7340032000 2009-09-17 18:52 fedora11.img

So, as far as permissions go, there's nothing wrong with the image file used as a disk for the VM. Image file creation was made trough virt-manager (raw file).

In order to perform this install I had to execute a workaround, because install is not possible trough normal means due to bug #524109:

 1. Pick up a working VM
 2. Replace the ISO file backing up the cdrom device
 3. Add a new virtio disk, remove the old disk
 4. Mark the vm to boot using the CD

In this case, it's not clear to me whether this defect is actually virt-manager's fault, or one of the underlying pieces (as libvirt and qemu).
Comment 1 Lucas Meneghel Rodrigues 2009-09-17 18:14:38 EDT
Created attachment 361573 [details]
Screenshot of the install failure

This is the error message I've got during the final stage of Fedora 11 GA install.
Comment 2 Mark McLoughlin 2009-09-21 12:36:25 EDT
Interesting, can't think what might be causing this

Can you reproduce something similar using rawhide qemu-kvm directly from the command line?

Could you include ~/.virt-manager/virt-manager.log and /var/log/libvirt/qemu/$guest.log
Comment 3 Bug Zapper 2009-11-16 07:35:13 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Cole Robinson 2009-11-16 13:50:55 EST
Closing as WORKSFORME. Please reopen if you can still reproduce.
Comment 5 Lucas Meneghel Rodrigues 2009-11-17 20:13:33 EST
Indeed as of latest rawhide it's working great, thanks Cole!

Note You need to log in before you can comment on or make changes to this bug.