Bug 52413 - /etc/X11/fs/config missing font paths
/etc/X11/fs/config missing font paths
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-23 12:53 EDT by Peter Bowen
Modified: 2007-04-18 12:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-31 16:45:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add directories to the font catalogue (731 bytes, patch)
2001-08-23 12:54 EDT, Peter Bowen
no flags Details | Diff

  None (edit)
Description Peter Bowen 2001-08-23 12:53:24 EDT
There are numerous directories missing out of the default config file for
xfs.  The attached patch adds back the directories that have been in
previous versions, and should fix the font problems people have been
complaining about.
Comment 1 Peter Bowen 2001-08-23 12:54:23 EDT
Created attachment 29254 [details]
Patch to add directories to the font catalogue
Comment 2 Glen Foster 2001-08-24 13:07:55 EDT
This defect is considered SHOULD-FIX for Fairfax.
Comment 3 Trond Eivind Glomsrxd 2001-08-31 16:44:58 EDT
Was this a fresh install or an upgrade?
Comment 4 Mike A. Harris 2001-09-02 01:19:00 EDT
Fixed in 4.1.0-1.2 in rawhide.  Don't know if it will be in final release or
not.  Might have to wait until erratum.
Comment 5 Peter Bowen 2001-09-02 13:24:19 EDT
This looks like it was it was mostly fixed in 4.1.0-1, which was in RC2, and
presumably will be in the final release.

As to upgrade vs. full install, they both behave the same because the line in
the specfile is:
%config %verify(not md5 size mtime) /etc/X11/fs/config

Without the noreplace option, the config file from the new/upgraded package will
_always_ replace the existing one, saving the old one as .rpmsave if necessary.

Note You need to log in before you can comment on or make changes to this bug.