Bug 524136 - saving graphs in octave
Summary: saving graphs in octave
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: octave
Version: 11
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Rakesh Pandit
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-18 03:02 UTC by Bill
Modified: 2009-11-04 18:21 UTC (History)
4 users (show)

Fixed In Version: 3.2.3-1.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-04 12:25:59 UTC


Attachments (Terms of Use)

Description Bill 2009-09-18 03:02:23 UTC
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US) AppleWebKit/532.0 (KHTML, like Gecko) Chrome/4.0.208.0 Safari/532.0

When I use print -dpng 'filename' the conversion drops xlabels, ylabels, and title from the graph.  It keeps axis labels and legend.  

Reproducible: Always

Steps to Reproduce:
1.plot(x,y)
2.xlabel('x-axis')
3.ylabel('y-axis')
4. print  -dpng 'foo.png'

Actual Results:  
gdImageStringFT: Could not find/open font while printing string response with font Helvetica
gdImageStringFT: Could not find/open font while printing string radians with font Helvetica
gdImageStringFT: Could not find/open font while printing string title with font Helvetica


Expected Results:  
graph with xlabel, ylabel, title

Comment 1 Fedora Update System 2009-10-20 00:07:52 UTC
plplot-5.9.5-1.fc11,pfstools-1.7.0-8.fc11,GMT-4.5.0-4.fc11,octave-forge-20090607-15.fc11,octave-3.2.3-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/plplot-5.9.5-1.fc11,pfstools-1.7.0-8.fc11,GMT-4.5.0-4.fc11,octave-forge-20090607-15.fc11,octave-3.2.3-1.fc11

Comment 2 Alex Lancaster 2009-10-27 21:10:58 UTC
I can't reproduce this any more with the update.

Comment 3 Alex Lancaster 2009-10-27 21:13:53 UTC
Fixes it for me too.  Can you visit the bodhi update:

http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10548

login and give it a positive karma point if it fixes it for you too?

Comment 4 Fedora Update System 2009-11-04 12:25:26 UTC
mathgl-1.9-6.fc11.1, plplot-5.9.5-1.fc11, pfstools-1.7.0-8.fc11, GMT-4.5.0-4.fc11, octave-forge-20090607-15.fc11, octave-3.2.3-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.