Bug 524137 - gnome-screenshot does not remember all settings - inconsistent behaviour.
Summary: gnome-screenshot does not remember all settings - inconsistent behaviour.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-utils
Version: 13
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-18 03:32 UTC by David Le Sage
Modified: 2010-04-30 04:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-30 04:35:37 UTC


Attachments (Terms of Use)

Description David Le Sage 2009-09-18 03:32:34 UTC
Description of problem:
The user takes a screenshot via Applications -> Accessories -> Take Screenshot. (That is, gnome-screenshot --interactive).  The user may choose some options, such as grabbing after a delay and grabbing the current window.

The next time the applet is launched, the program remembers the delay setting but not defaults back to the radio tick box for grabbing the whole desktop.  Surely it should either remember both settings, for the sake of consistency or neither?

Version-Release number of selected component (if applicable):
GNOME 2.26.1

How reproducible:
Every time.

Steps to Reproduce:
1. Go to  Applications -> Accessories -> Take Screenshot.
2. Set to "Grab the current window" by clicking the radio box.
3. Set delay to four seconds.
4. Take an image and save it.
5. Launch the screenshot applet again.  
6. The time delay has been "remembered" (it is still set to four seconds) but the other option has defaulted back to  "Grab the whole desktop."
  
Actual results:
One setting is remembered but the other is forgotten and goes back to the default.

Expected results:
Both settings should be remembered.

Additional info:

Comment 1 Matthias Clasen 2010-04-08 00:36:14 UTC
The code to do that was disabled forever, and finally removed in 2008:

http://git.gnome.org/browse/gnome-utils/commit/?id=9e38e2586eb4ee424c47b9752cb14ba104db4559

The reason for disabling it was that it 'breaks' the screenshot keybindings. You could arguably have added cmdline options for overriding gconf and use those in the keybindings, but meh.

Comment 2 David Le Sage 2010-04-08 00:43:39 UTC
Okay.  Thanks for the explanation.

Comment 3 Matthias Clasen 2010-04-30 04:35:37 UTC
I think I am going to close this bug. If you feel strongly about this, please file an upstream bug with the suggestion from comment 1, thanks.


Note You need to log in before you can comment on or make changes to this bug.