Bug 524143 - soft lockup on xen hvm
Summary: soft lockup on xen hvm
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen
Version: 5.3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Xen Maintainance List
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-18 05:48 UTC by Hushan Jia
Modified: 2009-09-18 06:17 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-18 06:17:48 UTC


Attachments (Terms of Use)
dmesg on guest (12.12 KB, text/plain)
2009-09-18 05:48 UTC, Hushan Jia
no flags Details

Description Hushan Jia 2009-09-18 05:48:51 UTC
Created attachment 361599 [details]
dmesg on guest

Description of problem:
soft lockup is show when pause a xen hvm vm.

Version-Release number of selected component (if applicable):
host:
2.6.18-128.el5xen
guest:
2.6.18-128.el5.

How reproducible:
Sometimes.

Steps to Reproduce:
1. install a hvm on rhel5.3 and start.
2. run xm pause <id> to pause the vm.
3. sometimes soft lockup is shown on hvm console. dmesg is attached.
  
Actual results:
BUG: soft lockup - CPU#0 stuck for 10s! [swapper:0]

Expected results:
no soft lockup.

Additional info:
dmesg:

Comment 1 Hushan Jia 2009-09-18 05:50:45 UTC
console output:

BUG: soft lockup - CPU#0 stuck for 10s! [swapper:0]

Pid: 0, comm:              swapper
EIP: 0060:[<c0428ba7>] CPU: 0
EIP is at __do_softirq+0x57/0x114
 EFLAGS: 00000286    Not tainted  (2.6.18-128.el5 #1)
EAX: c072b380 EBX: c06f0f24 ECX: 00000000 EDX: 00cd8b00
ESI: 00000002 EDI: c06e6b00 EBP: 0000000a DS: 007b ES: 007b
CR0: 8005003b CR2: b7fbe000 CR3: 1fe69000 CR4: 000006d0
 [<c04073eb>] do_softirq+0x52/0x9c
 [<c04059d7>] apic_timer_interrupt+0x1f/0x24
 [<c04145d6>] apm_bios_call_simple+0x9f/0xfc
 [<c0414dde>] apm_cpu_idle+0xf2/0x1e8
 [<c0403ca8>] cpu_idle+0x9f/0xb9
 [<c06f59ee>] start_kernel+0x379/0x380
 =======================

Comment 2 Chris Lalancette 2009-09-18 06:17:48 UTC
Yes, this is completely expected.  Because you are running an unmodified guest under Xen HVM, when you do an "xm pause", the domain just isn't scheduled.  Once you unpause it, it looks to the domain like it's been stuck for some length of time, and you'll get softlockup messages.

There isn't really a whole lot we can do about this (at least not without adding some kind of paravirtualized interface, which is probably not worth the effort).  I'm going to close this out.

Chris Lalancette


Note You need to log in before you can comment on or make changes to this bug.