Bug 524145 - WindowMaker crashes on switching to virtual terminals
Summary: WindowMaker crashes on switching to virtual terminals
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: WindowMaker
Version: 11
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-18 06:04 UTC by Suvayu
Modified: 2009-10-20 14:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-20 14:45:42 UTC


Attachments (Terms of Use)

Description Suvayu 2009-09-18 06:04:33 UTC
Description of problem:
Switching to virtual terminals using Ctrl+Alt+Fn kills WindowMaker. On coming back to GUI using Ctrl+Alt+F7 I am back to GDM login screen.

Version-Release number of selected component (if applicable):
0.92.0-19.fc11

How reproducible:
every time

Steps to Reproduce:
1.login to WindowMaker
2.switch to virtual terminal using Ctrl+Alt+Fn
3.switch back using Ctrl+Alt+F7
  
Actual results:
on switching back to GUI, instead of the desktop I am back to the GDM login screen.

Expected results:
on switching back to GUI, I should be back to my WindowMaker desktop.

Additional info:

Comment 1 Suvayu 2009-09-20 16:01:11 UTC
Hi,

It seems this is a bug in Xorg. I can replicate this in KDE and XFCE. However I couldn't find anything that looked related to this in Xorg.0.log. Which package should I file this bug against?

Comment 2 Suvayu 2009-10-20 14:45:42 UTC
The problem seems to have gone away since I switched drivers from Radeonhd to catalyst. However I tested on Radeon test day with the live CD for Rawhide (F12), and it passed the test where I needed to switch to VTs several times. So I guess this issue is resolved in the next release.


Note You need to log in before you can comment on or make changes to this bug.