Bug 524180 - T61 fails to correctly resume from S3 [NEEDINFO]
Summary: T61 fails to correctly resume from S3
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: hal
Version: 5.4
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Richard Hughes
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-18 09:03 UTC by Hushan Jia
Modified: 2014-06-02 13:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-02 13:19:11 UTC
pm-rhel: needinfo? (hjia)


Attachments (Terms of Use)
lshal output (110.35 KB, text/plain)
2009-09-24 01:48 UTC, Hushan Jia
no flags Details

Description Hushan Jia 2009-09-18 09:03:19 UTC
Description of problem:
The system cannot resume after suspend on thinkpad notebook.

Version-Release number of selected component (if applicable):
RHEL5.4, 2.6.18-164.el5.
Thinkpad T61.

How reproducible:
always

Steps to Reproduce:
1. select System->Suspend
2. close the lid and open or press power button
3. the screen is always black, system not resumed.
  
Actual results:
cannot resume.

Expected results:
can resume.

Additional info:
[hushan@hushan-t ~]$ cat /proc/cpuinfo 
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 23
model name      : Intel(R) Core(TM)2 Duo CPU     T8300  @ 2.40GHz
stepping        : 6
cpu MHz         : 800.000
cache size      : 3072 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
apicid          : 0
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe lm constant_tsc ida pni monitor ds_cpl vmx est tm2 cx16 xtpr lahf_lm
bogomips        : 4788.38
......

log messages:
Sep 18 16:47:53 hushan-t gnome-power-manager: (hushan) Suspending computer because the DBUS method Suspend() was invoked
Sep 18 16:47:59 hushan-t kernel: Disabling non-boot CPUs ...
Sep 18 16:47:59 hushan-t kernel: Breaking affinity for irq 9
Sep 18 16:47:59 hushan-t kernel: Breaking affinity for irq 12
Sep 18 16:47:59 hushan-t kernel: Breaking affinity for irq 14
Sep 18 16:47:59 hushan-t kernel: Breaking affinity for irq 82
Sep 18 16:47:59 hushan-t kernel: Breaking affinity for irq 98
Sep 18 16:47:59 hushan-t kernel: Breaking affinity for irq 122
Sep 18 16:47:59 hushan-t kernel: CPU 1 is now offline
Sep 18 16:47:59 hushan-t kernel: SMP alternatives: switching to UP code
Sep 18 16:48:08 hushan-t restorecond: Read error (Interrupted system call)
Sep 18 16:48:08 hushan-t kernel: CPU1 is down
Sep 18 16:48:08 hushan-t kernel: Stopping tasks: ========================================================================================================================================================|
Sep 18 16:48:08 hushan-t kernel:  usbdev3.2_ep83: PM: suspend 0->2, parent 3-2:1.0 already 1
Sep 18 16:48:08 hushan-t kernel:  usbdev3.2_ep02: PM: suspend 0->2, parent 3-2:1.0 already 1
Sep 18 16:48:08 hushan-t kernel:  usbdev3.2_ep81: PM: suspend 0->2, parent 3-2:1.0 already 1
Sep 18 16:48:08 hushan-t kernel: ACPI: PCI interrupt for device 0000:15:00.0 disabled
Sep 18 16:48:08 hushan-t kernel: ACPI: PCI interrupt for device 0000:00:1f.2 disabled
Sep 18 16:48:08 hushan-t kernel: ACPI: PCI interrupt for device 0000:00:1d.7 disabled
Sep 18 16:48:08 hushan-t kernel: ACPI: PCI interrupt for device 0000:00:1d.2 disabled
Sep 18 16:48:08 hushan-t kernel: ACPI: PCI interrupt for device 0000:00:1d.1 disabled
Sep 18 16:48:08 hushan-t kernel: ACPI: PCI interrupt for device 0000:00:1d.0 disabled
Sep 18 16:48:08 hushan-t kernel: ACPI: PCI interrupt for device 0000:00:1b.0 disabled
Sep 18 16:48:08 hushan-t kernel: ACPI: PCI interrupt for device 0000:00:1a.7 disabled
Sep 18 16:48:08 hushan-t kernel: ACPI: PCI interrupt for device 0000:00:1a.1 disabled
Sep 18 16:48:08 hushan-t kernel: ACPI: PCI interrupt for device 0000:00:1a.0 disabled
Sep 18 16:48:08 hushan-t kernel: ACPI: PCI interrupt for device 0000:00:19.0 disabled
Sep 18 16:48:08 hushan-t kernel: Intel machine check architecture supported.
Sep 18 16:48:08 hushan-t kernel: Intel machine check reporting enabled on CPU#0.
Sep 18 16:48:08 hushan-t kernel: ACPI: PCI Interrupt 0000:00:01.0[A] -> GSI 16 (level, low) -> IRQ 169
Sep 18 16:48:08 hushan-t kernel: ACPI: PCI Interrupt 0000:00:19.0[A] -> GSI 20 (level, low) -> IRQ 177
Sep 18 16:48:08 hushan-t kernel: ACPI: PCI Interrupt 0000:00:1a.0[A] -> GSI 20 (level, low) -> IRQ 177
Sep 18 16:48:08 hushan-t kernel: usb usb3: root hub lost power or was reset
Sep 18 16:48:08 hushan-t kernel: ACPI: PCI Interrupt 0000:00:1a.1[B] -> GSI 21 (level, low) -> IRQ 185
Sep 18 16:48:08 hushan-t kernel: usb usb4: root hub lost power or was reset
Sep 18 16:48:08 hushan-t kernel: ACPI: PCI Interrupt 0000:00:1a.7[C] -> GSI 22 (level, low) -> IRQ 193
Sep 18 16:48:08 hushan-t kernel: usb usb1: root hub lost power or was reset
Sep 18 16:48:08 hushan-t kernel: ehci_hcd 0000:00:1a.7: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
Sep 18 16:48:08 hushan-t kernel: PCI: Enabling device 0000:00:1b.0 (0100 -> 0102)
Sep 18 16:48:08 hushan-t kernel: ACPI: PCI Interrupt 0000:00:1b.0[B] -> GSI 17 (level, low) -> IRQ 82
Sep 18 16:48:08 hushan-t kernel: ACPI: PCI Interrupt 0000:00:1c.0[A] -> GSI 20 (level, low) -> IRQ 177
Sep 18 16:48:08 hushan-t kernel: ACPI: PCI Interrupt 0000:00:1c.1[B] -> GSI 21 (level, low) -> IRQ 185
Sep 18 16:48:08 hushan-t kernel: ACPI: PCI Interrupt 0000:00:1c.2[C] -> GSI 22 (level, low) -> IRQ 193
Sep 18 16:48:08 hushan-t kernel: ACPI: PCI Interrupt 0000:00:1c.3[D] -> GSI 23 (level, low) -> IRQ 201
Sep 18 16:48:08 hushan-t kernel: ACPI: PCI Interrupt 0000:00:1c.4[A] -> GSI 20 (level, low) -> IRQ 177
Sep 18 16:48:08 hushan-t kernel: ACPI: PCI Interrupt 0000:00:1d.0[A] -> GSI 16 (level, low) -> IRQ 169
Sep 18 16:48:08 hushan-t kernel: usb usb5: root hub lost power or was reset
Sep 18 16:48:08 hushan-t kernel: ACPI: PCI Interrupt 0000:00:1d.1[B] -> GSI 17 (level, low) -> IRQ 82
Sep 18 16:48:08 hushan-t kernel: usb usb6: root hub lost power or was reset
Sep 18 16:48:08 hushan-t kernel: ACPI: PCI Interrupt 0000:00:1d.2[C] -> GSI 18 (level, low) -> IRQ 90
Sep 18 16:48:08 hushan-t kernel: usb usb7: root hub lost power or was reset
Sep 18 16:48:08 hushan-t kernel: ACPI: PCI Interrupt 0000:00:1d.7[D] -> GSI 19 (level, low) -> IRQ 74
Sep 18 16:48:08 hushan-t kernel: usb usb2: root hub lost power or was reset
Sep 18 16:48:08 hushan-t kernel: ehci_hcd 0000:00:1d.7: debug port 1
Sep 18 16:48:08 hushan-t kernel: ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
Sep 18 16:48:08 hushan-t kernel: ACPI: PCI Interrupt 0000:00:1f.2[B] -> GSI 16 (level, low) -> IRQ 169
Sep 18 16:48:08 hushan-t kernel: ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
Sep 18 16:48:08 hushan-t kernel: e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX/TX
Sep 18 16:48:08 hushan-t kernel: ata1.00: ACPI cmd f5/00:00:00:00:00:a0 filtered out
Sep 18 16:48:08 hushan-t kernel: ACPI: PCI Interrupt 0000:15:00.0[A] -> GSI 16 (level, low) -> IRQ 169
Sep 18 16:48:08 hushan-t kernel: pnp: Device 00:08 does not support activation.
Sep 18 16:48:08 hushan-t kernel: pnp: Device 00:09 does not support activation.
Sep 18 16:48:08 hushan-t kernel: ata1.00: ACPI cmd f5/00:00:00:00:00:a0 filtered out
Sep 18 16:48:08 hushan-t kernel: ata1.00: configured for UDMA/133
Sep 18 16:48:08 hushan-t kernel: ata1.00: configured for UDMA/133
Sep 18 16:48:08 hushan-t kernel: ata1: EH complete
Sep 18 16:48:08 hushan-t kernel: SCSI device sda: 312581808 512-byte hdwr sectors (160042 MB)
Sep 18 16:48:08 hushan-t kernel: sda: Write Protect is off
Sep 18 16:48:08 hushan-t kernel: SCSI device sda: drive cache: write back
Sep 18 16:48:08 hushan-t kernel: SCSI device sda: 312581808 512-byte hdwr sectors (160042 MB)
Sep 18 16:48:08 hushan-t kernel: sda: Write Protect is off
Sep 18 16:48:08 hushan-t kernel: SCSI device sda: drive cache: write back
Sep 18 16:48:08 hushan-t kernel:  usbdev3.2_ep81: PM: resume from 0, parent 3-2:1.0 still 1
Sep 18 16:48:08 hushan-t kernel:  usbdev3.2_ep02: PM: resume from 0, parent 3-2:1.0 still 1
Sep 18 16:48:08 hushan-t kernel:  usbdev3.2_ep83: PM: resume from 0, parent 3-2:1.0 still 1
Sep 18 16:48:08 hushan-t kernel: Restarting tasks...<6>usb 3-2: USB disconnect, address 2
Sep 18 16:48:08 hushan-t kernel:  done
Sep 18 16:48:08 hushan-t kernel: Enabling non-boot CPUs ...
Sep 18 16:48:08 hushan-t kernel: SMP alternatives: switching to SMP code
Sep 18 16:48:08 hushan-t kernel: Booting processor 1/1 eip 11000
Sep 18 16:48:08 hushan-t kernel: CPU 1 irqstacks, hard=c0762000 soft=c0742000
Sep 18 16:48:08 hushan-t kernel: Initializing CPU#1
Sep 18 16:48:08 hushan-t kernel: Calibrating delay using timer specific routine.. 4788.13 BogoMIPS (lpj=2394068)
Sep 18 16:48:08 hushan-t kernel: monitor/mwait feature present.
Sep 18 16:48:08 hushan-t kernel: CPU: L1 I cache: 32K, L1 D cache: 32K
Sep 18 16:48:08 hushan-t kernel: CPU: L2 cache: 3072K
Sep 18 16:48:08 hushan-t kernel: CPU: Physical Processor ID: 0
Sep 18 16:48:08 hushan-t kernel: CPU: Processor Core ID: 1
Sep 18 16:48:08 hushan-t kernel: Intel machine check architecture supported.
Sep 18 16:48:08 hushan-t kernel: Intel machine check reporting enabled on CPU#1.
Sep 18 16:48:08 hushan-t kernel: CPU1: Intel(R) Core(TM)2 Duo CPU     T8300  @ 2.40GHz stepping 06
Sep 18 16:48:08 hushan-t kernel: CPU1 is up
Sep 18 16:48:08 hushan-t kernel: usb 3-2: new full speed USB device using uhci_hcd and address 3
Sep 18 16:48:09 hushan-t kernel: usb 3-2: configuration #1 chosen from 1 choice
Sep 18 16:48:13 hushan-t gnome-power-manager: (hushan) Resuming computer
Sep 18 16:51:28 hushan-t syslogd 1.4.1: restart.
Sep 18 16:51:28 hushan-t kernel: klogd 1.4.1, log source = /proc/kmsg started.
Sep 18 16:51:28 hushan-t kernel: Linux version 2.6.18-164.el5 (mockbuild@x86-002.build.bos.redhat.com) (gcc version 4.1.2 20080704 (Red Hat 4.1.2-46)) #1 SMP Tue Aug 18 15:51:54 EDT 2009 <==== hard reboot

Comment 1 Matthew Garrett 2009-09-22 18:25:43 UTC
Can you please attach the output of the lshal command?

Comment 2 Hushan Jia 2009-09-24 01:48:58 UTC
Created attachment 362375 [details]
lshal output

Comment 3 Matthew Garrett 2009-09-28 22:22:29 UTC
Does suspending by using the pm-suspend command with any of the --quirk options result in it working successfully?

Comment 4 Hushan Jia 2009-10-09 01:31:37 UTC
I tried 

--quirk-dpms-suspend
--quirk-vga-mode3
--quirk-radeon-off

and they are ok, system can resume correctly.

Comment 5 Matthew Garrett 2009-11-03 20:15:40 UTC
Reassigning to hal so the correct quirks can be applied automatically

Comment 6 Richard Hughes 2009-11-12 09:22:41 UTC
(In reply to comment #4)
> I tried 
> 
> --quirk-dpms-suspend
> --quirk-vga-mode3
> --quirk-radeon-off

Does your machine have a radeon graphics card? It looks like an intel card from here. Does just --quirk-dpms-suspend make things work as well? Thanks.

Comment 7 Hushan Jia 2009-11-13 01:24:11 UTC
(In reply to comment #6)
> (In reply to comment #4)
> > I tried 
> > 
> > --quirk-dpms-suspend
> > --quirk-vga-mode3
> > --quirk-radeon-off
> 
> Does your machine have a radeon graphics card? It looks like an intel card from
> here. Does just --quirk-dpms-suspend make things work as well? Thanks.  

The graphics card is nvidia Quadro NVS 140M.
And yes, using pm-suspend --quirk-dpms-suspend can suspend and resume correctly.

Comment 11 RHEL Product and Program Management 2014-03-07 13:44:53 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 12 RHEL Product and Program Management 2014-06-02 13:19:11 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).


Note You need to log in before you can comment on or make changes to this bug.