Bug 52419 - lilo-21.4.4 won't boot ReiserFS without notail
lilo-21.4.4 won't boot ReiserFS without notail
Status: CLOSED WONTFIX
Product: Red Hat Public Beta
Classification: Retired
Component: lilo (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-23 13:27 EDT by Marcelo Roberto Jimenez
Modified: 2007-04-18 12:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-23 13:27:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcelo Roberto Jimenez 2001-08-23 13:27:21 EDT
Description of Problem:
I know that ReiserFS is not supported and I know that this bug is supposed
to be closed WONTFIX, and I know that grub is now the default boot loader,
etc, etc, etc. But, once you took the time to remodel anaconda to work with
other file systems, including ReiserFS, it's worth to note that lilo-21.4
cannot boot from ReiserFS partitions that were not created/mounted with the
NOTAIL option. It's necessary to use at least lilo-21.6 to boot from
ReiserFS partitions without notail.

Anyway folks, it's up to you. Regards,

Marcelo Jimenez.

Version-Release number of selected component (if applicable):
lilo-21.4.4

How Reproducible:
Totally reproducible.

Steps to Reproduce:
1. Create a kernel inside a ReiserFS partition that was not mounted with
the NOTAIL option.
2. run lilo.
3. reboot.

Actual Results:
It won't boot.

Expected Results:
It's supposed boot.

Additional Information:
Comment 1 Doug Ledford 2001-08-23 19:18:10 EDT
Your comments about me not being able to do anything about this due to ReiserFS
not being supported and lilo not being the default boot loader are correct. 
It's also too late in the process to change lilo unless there is a problem that
*is* related to a supported feature/component.  So, you are also right that I'm
closing this as WONTFIX, but I will say that your comment has been duly noted
and I'm Cc:ing Preston Brown on this just so he will see the comment as well.

Note You need to log in before you can comment on or make changes to this bug.