Bug 524204 - 2.6.30+ (F11, F12). Digitizers blacklisting disables the Saitek X52 joystick
Summary: 2.6.30+ (F11, F12). Digitizers blacklisting disables the Saitek X52 joystick
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-18 11:38 UTC by Gilboa Davara
Modified: 2011-06-23 11:26 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-23 11:26:30 UTC


Attachments (Terms of Use)
udev monitor log (5.45 KB, text/plain)
2009-09-18 11:38 UTC, Gilboa Davara
no flags Details
joydev.c blacklisting reversal (548 bytes, text/plain)
2009-12-16 08:39 UTC, Gilboa Davara
no flags Details
Makefile used to build joydev_fixed.ko (333 bytes, text/plain)
2009-12-16 08:40 UTC, Gilboa Davara
no flags Details

Description Gilboa Davara 2009-09-18 11:38:39 UTC
Created attachment 361629 [details]
udev monitor log

Description of problem:
Saitek X52 USB joystick, worked since day one (F9)
Kernel recently upgraded to 2.6.30.5-53.

Version-Release number of selected component (if applicable):
kernel-2.6.30.5-43.fc11.x86_64
udev-141-4.fc11.x86_64

How reproducible:
Always.

Comment 1 Gilboa Davara 2009-09-18 11:42:48 UTC
Kernel log.
$ dmesg -c
usb 1-4.1.4: USB disconnect, address 10
usb 1-4.1.4: new full speed USB device using ehci_hcd and address 11
usb 1-4.1.4: New USB device found, idVendor=06a3, idProduct=0762
usb 1-4.1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 1-4.1.4: Product: Saitek X52 Pro Flight Control System
usb 1-4.1.4: Manufacturer: Saitek
usb 1-4.1.4: configuration #1 chosen from 1 choice
input: Saitek Saitek X52 Pro Flight Control System as /devices/pci0000:00/0000:00:1d.7/usb1/1-4/1-4.1/1-4.1.4/1-4.1.4:1.0/input/input11
generic-usb 0003:06A3:0762.0006: input,hidraw2: USB HID v1.11 Joystick [Saitek Saitek X52 Pro Flight Control System] on usb-0000:00:1d.7-4.1.4/input0

Comment 2 Gilboa Davara 2009-09-18 11:46:57 UTC
That's weird - manual mknod doesn't seem to help.
Looks like a kernel issue.

$ cd /dev/input/
$ mknod js0 c 13 0
$ jstest /dev/input/js0
jstest: No such device

Comment 3 Maximilian Güntner 2009-10-04 00:24:34 UTC
This bug is related to a bad commit to joydev which now blacklists x52 joysticks.(d07a9cba6be5c0e947afc1014b5a62182a86f1f1)

Here's the kernel.org bugzilla thread (which a revert patch):

http://bugzilla.kernel.org/show_bug.cgi?id=14049

This bug on launchpad:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/300143

org.kernel.vger.linux-input discussion:

http://markmail.org/message/5jraw2mk6k6nvlos#query:+page:1+mid:5jraw2mk6k6nvlos+state:results

Comment 4 G. Michael Carter 2009-10-23 21:21:26 UTC
Is there any workarounds?

Comment 5 Maximilian Güntner 2009-10-23 22:20:31 UTC
You either need to downgrade your kernel (version < 2.6.30) or you have to compile yourself a custom kernel without the bad lines.

You'll need this patch,
http://bugzilla.kernel.org/attachment.cgi?id=23054

If the patch does not fit your kernel version, simply remove these lines manually from "drivers/input/joydev.c":

       {
               .flags = INPUT_DEVICE_ID_MATCH_EVBIT |
                               INPUT_DEVICE_ID_MATCH_KEYBIT,
               .evbit = { BIT_MASK(EV_KEY) },
               .keybit = { [BIT_WORD(BTN_DIGI)] = BIT_MASK(BTN_DIGI) },
       },      /* Avoid tablets, digitisers and similar devices */

Comment 6 Gilboa Davara 2009-11-08 10:47:38 UTC
Given the fact that the bad commit [1] was removed ~2 months ago, any chance that Fedora will do the same before F12GA?

- Gilboa
[1] http://bugzilla.kernel.org/show_bug.cgi?id=14049

Comment 7 G. Michael Carter 2009-11-16 17:29:42 UTC
I tested this in the F12 LiveCD and it's still a problem.   How do we get the fix in the stock kernel?

Comment 8 Gilboa Davara 2009-11-29 17:34:06 UTC
Reminder: F12 GA doesn't solve this issue.

... Please, please, please reverse this patch. Upstream is taking its time fixing this issue, and I'm stuck at F11/2.6.29.

- Gilboa

Comment 9 Gilboa Davara 2009-12-16 08:38:40 UTC
Given the fact the upstream doesn't seem to be too keen to reverse this blacklisting and given the lack of response from Fedora's kernel people, here's Gilboa's short (and ugly) guide to fixing the missing X52 problem. (For those of you who rather not roll your own kernel...)

0. Make sure you have installed the "Development Tools" package group and the kernel-devel package.
1. Download the latest kernel SRPM from http://download.fedora.redhat.com/pub/fedora/linux/updates/. (I dislike yumdownloader...)
2. Use file-roller and click on linux-2.6.xx.tar.bz (which will open a new window.)
3. Unpack drivers/input/joydev.c and place it in an empty directory.
4. Download the attached Makefile and joydev.spec files and place them in the same directory.
5. CD into this directory, and execute:
$ patch -p0 < joydev.patch
$ make
$ su
$ make install
$ blacklist joydev > /etc/modprobe.d/x52_fix.conf
$ modprobe joydev_fixed
$ exit
6. Profit.

P.S. This produced must be repeated each time a new kernel is installed.
P.S.2. Make sure you delete the /etc/modprobe.d/x52_fix.conf once this bug is resolved. 

- Gilboa

Comment 10 Gilboa Davara 2009-12-16 08:39:40 UTC
Created attachment 378709 [details]
joydev.c blacklisting reversal

Comment 11 Gilboa Davara 2009-12-16 08:40:14 UTC
Created attachment 378710 [details]
Makefile used to build joydev_fixed.ko

Comment 12 Maximilian Güntner 2010-05-20 20:03:12 UTC
2.6.34 resolves the issue - no patch is needed anymore.
The commit that fixed it (kernel.org): 0b7024ac4df5821347141c18e680b7166bc1cb20

Comment 13 Gilboa Davara 2010-06-24 08:12:15 UTC
Still an issue in F13 (which still uses 2.6.33)
Any chance of fixing this issue with current released kernel?

- Gilboa

Comment 14 Bug Zapper 2011-06-02 17:43:40 UTC
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 15 Gilboa Davara 2011-06-04 18:26:51 UTC
Works out of the box in Fedora 14/15.
Please close.


Note You need to log in before you can comment on or make changes to this bug.