Bug 524256 - Init script needs a few fixes for LSB compliance
Summary: Init script needs a few fixes for LSB compliance
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hsqldb
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tomas Radej
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: InitScriptsProject 585125
TreeView+ depends on / blocked
 
Reported: 2009-09-18 14:53 UTC by Radek Bíba
Modified: 2012-05-29 21:53 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 585125 (view as bug list)
Environment:
Last Closed: 2012-05-29 21:53:18 UTC


Attachments (Terms of Use)

Description Radek Bíba 2009-09-18 14:53:58 UTC
Description of problem:
The hsqldb init script has the following issues:

* commands 'force-reload' and 'try-restart' aren't implemented.

* when hsqldb is unconfigured - typically its config file doesn't set a required variable such as JAVA_EXECUTABLE - attempt to start the service exits with code 2. This should be 6.

* attempt to start an already running service should exit with code 0, not 1.

* when the service is stopped and command 'status' is run, exit code should be 3, not 0.

* attempt to stop an already stopped service should exit with code 0, not 1.

* when the service isn't running but its lock file exists (the service died), command 'status' should explain the situation and exit with code 2.

* when the init script is executed with an unknown or invalid command, it should exit with code 2.

Version-Release number of selected component (if applicable):
hsqldb-1.8.0.10-2.fc11

Additional info:
See https://fedoraproject.org/wiki/Packaging/SysVInitScript for details.

Comment 1 Bug Zapper 2009-11-16 12:37:06 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 David Kovalsky 2010-04-15 15:44:37 UTC
ping - any updates on this bug?

Comment 5 Andrew Overholt 2010-04-23 13:25:37 UTC
I think Deepak gave up ownership of hsqldb.  See:

http://lists.fedoraproject.org/pipermail/java-devel/2010-April/003710.html

Comment 9 Bug Zapper 2010-11-04 09:56:16 UTC
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 10 Radek Bíba 2010-11-04 14:26:24 UTC
Still not fixed in F14.

Comment 11 Andrea V. 2012-05-14 19:35:42 UTC
Still not fixed in F16

Comment 12 Deepak Bhole 2012-05-14 21:15:32 UTC
Assigning to new owner.

Comment 13 Fedora Update System 2012-05-21 15:25:42 UTC
hsqldb-1.8.1.3-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/hsqldb-1.8.1.3-5.fc15

Comment 14 Fedora Update System 2012-05-21 15:26:51 UTC
hsqldb-1.8.1.3-5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/hsqldb-1.8.1.3-5.fc16

Comment 15 Fedora Update System 2012-05-22 02:19:34 UTC
Package hsqldb-1.8.1.3-5.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hsqldb-1.8.1.3-5.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8208/hsqldb-1.8.1.3-5.fc16
then log in and leave karma (feedback).

Comment 16 Radek Bíba 2012-05-22 07:42:49 UTC
Everything is all right now. Thanks much.

Comment 17 Fedora Update System 2012-05-29 21:53:18 UTC
hsqldb-1.8.1.3-5.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2012-05-29 21:53:36 UTC
hsqldb-1.8.1.3-5.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.