Bug 524273 - RHEL6 Alpha1: testVMX testsuite errors on P6
Summary: RHEL6 Alpha1: testVMX testsuite errors on P6
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gcc
Version: 6.0
Hardware: ppc64
OS: Linux
medium
medium
Target Milestone: rc
: 6.0
Assignee: Jakub Jelinek
QA Contact: Michal Nowak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-18 15:47 UTC by Jeff Bastian
Modified: 2018-10-27 11:13 UTC (History)
6 users (show)

Fixed In Version: gcc-4.4.1-16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-11 14:39:13 UTC


Attachments (Terms of Use)

Description Jeff Bastian 2009-09-18 15:47:29 UTC
Description of problem:
The testVMX test-suite -- which checks the correctness of Altivec/VMX instructions on POWER6 -- reported some errors on RHEL6 Alpha1 on a P6 system. The same test-suite runs fine on 5.4.

The testVMX suite is available at http://www.bsc.es/plantillaH.php?cat_id=215


Version-Release number of selected component (if applicable):
gcc-4.4.0-4.ppc64
gcc-c++-4.4.0-4.ppc64

How reproducible:
every time

Steps to Reproduce:
1. wget http://www.bsc.es/projects/deepcomputing/pblade/pblade_tuning/testVMX-0.2.2.tar.gz
2. tar xf testVMX-0.2.2.tar.gz; cd testVMX-0.2.2
3. make gcc
4. ./testVMX-gcc-32
5. ./testVMX-gcc-64
6. ./testVMX-g++-32
7. ./testVMX-g++-64

Actual results:
Function vec_cmpgt [type char]            ===> Error
Function vec_cmpgt [type short]           ===> Error
Function vec_cmpgt [type unsigned int]    ===> Error
Function vec_cmplt [type char]            ===> Error
Function vec_cmplt [type short]           ===> Error
Function vec_cmplt [type unsigned short]  ===> Error
Function vec_cmplt [type unsigned int]    ===> Error

Expected results:
no errors

Additional info:
Due to bug 511304 and bug 511908, you may need to install RHEL 6 from DVD (not a network install) on a non-blade system to reproduce.

Comment 2 RHEL Product and Program Management 2009-09-18 15:57:36 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Bill Nottingham 2009-09-18 19:41:02 UTC
Out of curiousity, if you put the test suite in a package, and build it in a build env/mock root, does that fail too?

Comment 4 Jakub Jelinek 2009-09-22 08:03:12 UTC
It fails even on Fedora 11 on G5.
Fixed thusly:
http://gcc.gnu.org/ml/gcc-patches/2009-09/msg01479.html
waiting for upstream approval.

For QA, it would be nice to put this testVMX testsuite into RHTS and grep for ===> Error lines.

Comment 5 Jakub Jelinek 2009-09-24 06:55:38 UTC
Fixed in gcc-4.4.1-16.

Comment 6 releng-rhel@redhat.com 2009-10-29 13:44:18 UTC
Fixed in 'gcc-4.4.1-16'. 'gcc-4.4.1-22.el6' included in compose 'RHEL6.0-20091028.0'.
Moving to ON_QA.

Comment 9 releng-rhel@redhat.com 2010-11-11 14:39:13 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.