Bug 524293 - bad: eric does not use qt4 designer, qt4 linguist
Summary: bad: eric does not use qt4 designer, qt4 linguist
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: eric
Version: 11
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL: http://picpaste.com/Eric4bug.png
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-18 18:27 UTC by Fabian
Modified: 2009-10-14 01:47 UTC (History)
4 users (show)

Fixed In Version: 4.3.7.1-2.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-14 01:44:25 UTC


Attachments (Terms of Use)

Description Fabian 2009-09-18 18:27:58 UTC
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.3) Gecko/20090909 Fedora/3.5.3-1.fc11 Firefox/3.5.3

The Eric Python IDE trys to open the Qt3-designer instead of the qt4-designer(same thing goes for the linguist) as you can see in the error message. 

Reproducible: Always

Steps to Reproduce:
1. start eric
2.try to open the designer "Extra-Tools->"Designer 3..ยง
3.
Actual Results:  
it gives this error. 

Expected Results:  
This should be patched so eric uses Qt4 designer

Comment 1 Kevin Kofler 2009-09-18 18:34:16 UTC
As I wrote on IRC, it should be fixed to use the -qt4 suffixed tools.

Comment 2 Johan Cwiklinski 2009-09-18 18:50:22 UTC
Indeed, configuring eric to use "-qt4" suffix fix the issue.

I do not yet know wich file in the sources should be patched to achieve that. If someone knows that, he'll be welcome :)

Comment 3 Fedora Update System 2009-09-18 21:36:57 UTC
eric-4.3.7.1-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/eric-4.3.7.1-2.fc11

Comment 4 Fedora Update System 2009-09-18 21:37:04 UTC
eric-4.3.7.1-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/eric-4.3.7.1-2.fc10

Comment 5 Johan Cwiklinski 2009-09-18 21:39:42 UTC
eric-4.3.7.1-2 will put the -qt4 suffix by default, on fresh installs. If Eric has already been started, then you have a local user config file.
In that case, you should either delete local users config files for eric, or set manually the relevant suffix in the preferences window.

Comment 6 Fabian 2009-09-19 17:48:11 UTC
ok, I changed line 125,128 and line 132 my config file for the Qt part looks now like this:

[Qt]
DisableQt3=1
QtDir=/usr/lib64/qt-3.3
ExportQtDir=0
Qt4Dir=/usr/lib64/qt4
Qt4TranslationsDir=
QtToolsPrefix3=
QtToolsPostfix3=
QtToolsPrefix4=/usr/lib64/qt4/bin/
QtToolsPostfix4=

is this correct? Or should I change something else too?

Comment 7 Fedora Update System 2009-09-24 05:07:51 UTC
eric-4.3.7.1-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update eric'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9812

Comment 8 Fedora Update System 2009-09-24 05:18:27 UTC
eric-4.3.7.1-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update eric'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-9872

Comment 9 Fedora Update System 2009-10-14 01:44:17 UTC
eric-4.3.7.1-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2009-10-14 01:47:29 UTC
eric-4.3.7.1-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.