Bug 524302 - setroubleshoot: SELinux is preventing /usr/sbin/abrtd "setattr" access on .abrt.
Summary: setroubleshoot: SELinux is preventing /usr/sbin/abrtd "setattr" access on .abrt.
Keywords:
Status: CLOSED DUPLICATE of bug 524300
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:0a4c845ef28...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-18 18:56 UTC by andreasfrische+redhat
Modified: 2009-09-18 21:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-18 21:22:32 UTC


Attachments (Terms of Use)

Description andreasfrische+redhat 2009-09-18 18:56:22 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing /usr/sbin/abrtd "setattr" access on .abrt.

Detailed Description:

[abrtd has a permissive type (abrt_t). This access was not denied.]

SELinux denied access requested by abrtd. It is not expected that this access is
required by abrtd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:abrt_t:s0
Target Context                system_u:object_r:user_home_dir_t:s0
Target Objects                .abrt [ dir ]
Source                        abrtd
Source Path                   /usr/sbin/abrtd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           abrt-0.0.8.5-1.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-1.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31-23.fc12.x86_64
                              #1 SMP Wed Sep 16 15:54:05 EDT 2009 x86_64 x86_64
Alert Count                   1
First Seen                    Fri 18 Sep 2009 08:52:47 PM EDT
Last Seen                     Fri 18 Sep 2009 08:52:47 PM EDT
Local ID                      6de1112a-90f2-49a9-b373-7aa1361e5c7a
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1253321567.312:23): avc:  denied  { setattr } for  pid=1442 comm="abrtd" name=".abrt" dev=dm-0 ino=82549 scontext=system_u:system_r:abrt_t:s0 tcontext=system_u:object_r:user_home_dir_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1253321567.312:23): arch=c000003e syscall=90 success=yes exit=0 a0=1d79598 a1=1c0 a2=ffffffffffffff88 a3=7fff121efa40 items=0 ppid=1 pid=1442 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrtd" exe="/usr/sbin/abrtd" subj=system_u:system_r:abrt_t:s0 key=(null)


audit2allow suggests:

#============= abrt_t ==============
allow abrt_t user_home_dir_t:dir setattr;

Comment 1 Daniel Walsh 2009-09-18 21:22:32 UTC

*** This bug has been marked as a duplicate of bug 524300 ***


Note You need to log in before you can comment on or make changes to this bug.