Bug 524337 - Closing one application causes garbled audio from another
Summary: Closing one application causes garbled audio from another
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 11
Hardware: i586
OS: Linux
low
medium
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-19 01:10 UTC by Christopher Beland
Modified: 2010-06-28 14:43 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-28 14:43:58 UTC


Attachments (Terms of Use)
Output from pulseaudio -vvvv after audacious starts playing (46.87 KB, text/plain)
2009-09-19 22:34 UTC, Christopher Beland
no flags Details
Output of alsa-info.sh --no-upload (21.09 KB, text/plain)
2009-09-23 15:46 UTC, Christopher Beland
no flags Details

Description Christopher Beland 2009-09-19 01:10:55 UTC
I had four sound applications running:
* Rhythmbox
* Firefox (with a Flash application playing NPR)
* Audacious (playing a radio station streaming MP3)
* Epiphany (with a Flash application playing YouTube)

All of the applications were paused except Audacious, which was playing audio.  After I closed Epiphany, the Audacious audio output sounded garbled.  Opening Sound Preferences, the line "ALSA plug-in [audacious]" is appearing and disappearing.  It sounds like spurts of audio are being played at high speed, and then stopping, and starting again?  There are a few seconds of silence between bursts of garbled music.  Audacious keeps printing out "ERROR: neon: neon.c:970 (neon_aud_vfs_fread_impl): <0xb3b34aa8> Buffer underrun, trying rebuffering".

Hitting "Stop" in Audacious and then "Play" didn't fix the problem. Closing Firefox and trying "Stop" and "Play" in Audacious didn't fix the problem, but then after I closed Rhythmbox as well, I hit "Play" and I got normal audio from Audacious.

Software versions:
pulseaudio-0.9.15-17.fc11.i586
audacious-1.5.1-11.fc11.i586
rhythmbox-0.12.3-1.fc11.i586
firefox-3.5.3-1.fc11.i586
flash-plugin-10.0.32.18-release.i386
epiphany-2.26.3-4.fc11.i586

Comment 1 Christopher Beland 2009-09-19 22:34:26 UTC
Created attachment 361790 [details]
Output from pulseaudio -vvvv after audacious starts playing

Today I experienced similar symptoms with only audacious playing audio.  Its "place in track" indicator showed time passing at about 5 times normal, with scratchy fast forward-sounding audio to match.  After it happened the first time, I started pulseaudio with -vvvv, and it happened again.  It has happened both in the middle of an MP3, and right when the second MP3 on the playlist starts.

I excerpted the part of the output I get after audacious is already playing, until after I hit "Stop" in audacious.

Comment 2 Christopher Beland 2009-09-23 15:46:06 UTC
Created attachment 362323 [details]
Output of alsa-info.sh --no-upload

Today I was experiencing garbled output from audacious, despite closing and restarting the program.  It eventually became continuous, making the program completely unusable.  The only other application playing audio was Rhythmbox, which was paused.  I unpaused it, and hit "Play" in Audacious, which played music normally again.  I was able to re-pause Rhythmbox without any garbled output (at least for the next few minutes).

It seems there is a more general problem with the PulseAudio server getting confused when multiple applications are connected.  I am attaching more diagnostic info.

Comment 3 Adam Williamson 2009-10-20 19:58:16 UTC
it seems more to me like audacious is the common factor here; have you ever experienced this problem with any *other* application?

audacious does have a native PA output plugin, IIRC - have you tried using that rather than the ALSA output plugin? it should be better behaved.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 4 Christopher Beland 2010-03-13 08:07:49 UTC
Well, after upgrading to Fedora 12, I don't believe I've experienced any such symptoms.  I tried reproducing the bug by re-creating the circumstances in the initial report, but everything worked fine.  I see in Audacious' preferences that it's now using the PulseAudio output plugin by default.  Fine with me to close this, unless you want me to re-enable the ALSA output plugin and see if anything bad happens in daily use with F12.

Comment 5 Bug Zapper 2010-04-28 10:28:17 UTC
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 6 Bug Zapper 2010-06-28 14:43:58 UTC
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.