Bug 524366 - dracut promts password for luks when it doesn't need to
Summary: dracut promts password for luks when it doesn't need to
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-19 14:03 UTC by Kenneth Topp
Modified: 2011-05-04 12:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-04 12:10:21 UTC
Type: ---


Attachments (Terms of Use)

Description Kenneth Topp 2009-09-19 14:03:46 UTC
I have a unencrypted drive specified by root=UUID=.. in grub.conf
the system has varies encrypted drives.

dracut is prompting for passwords for one of the other block devices, even though the root block device is available.  I hit enter a couple times (it re-asks only for the same drive) and then it leaves me alone.

adding rd_NO_LUKS works to avoid this bug.

running koji's dracut-002-2.gitc53acc30 on x86_64

Comment 1 Harald Hoyer 2009-09-21 13:13:14 UTC
hmm, working as intended...

Comment 2 Kenneth Topp 2011-02-06 17:57:46 UTC
(In reply to comment #1)
> hmm, working as intended...

why is this a bug?  what is dracut's goal?  Is it not to get to the root fs?  why does it continue to prompt to decrypt filesystems beyond what it needs

Comment 3 Harald Hoyer 2011-02-08 11:56:30 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > hmm, working as intended...
> 
> why is this a bug?  what is dracut's goal?  Is it not to get to the root fs? 
> why does it continue to prompt to decrypt filesystems beyond what it needs

because dracut is an all purpose initramfs without any configuration, and it does not know what it does not have to do, to get to the root device. Normally anaconda (the installer) would write "rd_NO_LUKS" to the kernel command line.


Note You need to log in before you can comment on or make changes to this bug.