Bug 524367 - Running with radeon.modeset=0 and then running glxgears crashes machine
Summary: Running with radeon.modeset=0 and then running glxgears crashes machine
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dave Airlie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-19 14:07 UTC by Kevin DeKorte
Modified: 2009-09-30 05:47 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-30 05:47:50 UTC


Attachments (Terms of Use)

Description Kevin DeKorte 2009-09-19 14:07:17 UTC
Description of problem:

Running with radeon.modeset=0 and then running glxgears crashes machine

Version-Release number of selected component (if applicable):
Latest as of Sept 18, 2009 of kernel, libdrm and mesa

How reproducible:
100%

Steps to Reproduce:
1. Set radeon.modeset=0 on kernel command line
2. Login, and open terminal
3. run glxgears screen goes blank and machine does not respond to console change 
  
Actual results:
Blank powered down screens

Expected results:
running glxgears

Additional info:
machine has a rv635 card in it Asus Silent Magic 3650

Comment 1 Chuck Ebbert 2009-09-27 11:02:18 UTC
Please try with kernel 2.6.31.1-48 or later and report back whether it's still broken.

Comment 2 Kevin DeKorte 2009-09-28 16:11:33 UTC
Appears to be fixed with -48


Note You need to log in before you can comment on or make changes to this bug.