Bug 524374 - firefox crash with segmentation fault on certain pages
Summary: firefox crash with segmentation fault on certain pages
Keywords:
Status: CLOSED DUPLICATE of bug 512845
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: rawhide
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-19 15:03 UTC by Michael Stoykov
Modified: 2009-11-28 18:16 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-21 18:03:53 UTC


Attachments (Terms of Use)
segmentation fault trace (28.30 KB, text/plain)
2009-09-19 15:03 UTC, Michael Stoykov
no flags Details

Description Michael Stoykov 2009-09-19 15:03:09 UTC
Created attachment 361768 [details]
segmentation fault trace

Description of problem:
firefox crash with segmentation fault on certain pages

Version-Release number of selected component (if applicable):
xulrunner-1.9.1.3-1.fc12.x86_64
firefox-3.5.3-1.fc12.x86_64


How reproducible:
just open http://www.yolinux.com/TUTORIALS/LinuxTutorialCDBurn.html in firefox and wait a while

Steps to Reproduce:
1.
2.
3.
  
Actual results:
segmetation fault :)

Expected results:
no segmentation fault


Additional info:

this is not the only page it crashed on me but I don't remember any other at the moment AFAIK neither one of them had flash on them or any other strange technology.

Comment 1 Will Woods 2009-09-21 18:03:53 UTC
That page is *loaded* with flash. Chatted with reporter on IRC; installing flashblock works around the crash. 

Pretty sure this is that flash execmem+selinux bug everyone's been seeing.

*** This bug has been marked as a duplicate of bug 512845 ***

Comment 2 Michael Stoykov 2009-09-21 18:07:20 UTC
Just to add that it crash with this particular flash http://bin.clearspring.com/at/v/1/button1.6.swf and that I will report this to them and adobe as well :)

Comment 3 Daniel Walsh 2009-09-22 02:49:51 UTC
*** Bug 524693 has been marked as a duplicate of this bug. ***

Comment 4 Arne Chr. Jorgensen 2009-11-28 16:07:42 UTC
Just to add - it crash before it is opened. Just starting firefox. If any content cause anything, then it is the fedora start page.

Comment 5 Arne Chr. Jorgensen 2009-11-28 18:16:26 UTC
Disregard my comment above.  In my case it seem to be SELinux preventing it from running: "The firefox application attempted to change the access protection of memory
(e.g., allocated using malloc)."

The Automatic Bug Reporting Tool directed me to this page, and I didn't read this report in full before adding a comment. Sorry....


Note You need to log in before you can comment on or make changes to this bug.