This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 524381 - Segfaults in mdadm [NEEDINFO]
Segfaults in mdadm
Status: CLOSED DUPLICATE of bug 523862
Product: Fedora
Classification: Fedora
Component: mdadm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Doug Ledford
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-19 13:04 EDT by Bruno Wolff III
Modified: 2009-09-22 16:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-22 16:54:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
atorkhov: needinfo?


Attachments (Terms of Use)
dmesg file which includes some info about mdadm segfaults (37.40 KB, application/octet-stream)
2009-09-19 13:04 EDT, Bruno Wolff III
no flags Details

  None (edit)
Description Bruno Wolff III 2009-09-19 13:04:18 EDT
Created attachment 361775 [details]
dmesg file which includes some info about mdadm segfaults

Description of problem:
During the boot process I get segfaults reported during the boot process and in some cases (dracut initramfs/kernel combinations) this results in /dev/md0 from being used which keeps the boot from completing.

Version-Release number of selected component (if applicable):
mdadm-3.0-4.fc12.i686

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bruno Wolff III 2009-09-21 15:28:47 EDT
There is some tie in to dracut with this. I saw the same issue on an x86_64 machine where both the -23 and -33 kernels wouldn't complete booting and I ended up using mkinitrd to make an initrd img to use instead of an initramfs image from dracut.
Comment 2 Alexey Torkhov 2009-09-22 13:06:54 EDT
Seem to be duplicate of bug 523862.
Comment 3 Bruno Wolff III 2009-09-22 15:27:32 EDT
I agree.
What I suspect is that dracut ins't including some needed library in the initramfs. When I use a mkinitrd generated initrd image I don't see any problems.
Comment 4 Alexey Torkhov 2009-09-22 16:54:57 EDT
(In reply to comment #3)
> I agree.

Marking as duplicate then :)

> What I suspect is that dracut ins't including some needed library in the
> initramfs. When I use a mkinitrd generated initrd image I don't see any
> problems.  

It crashes for me even on normal system. Mkinitrd generated images have populated mdadm.conf, not sure about dracut ones - may be it tries to scan and fails.

*** This bug has been marked as a duplicate of bug 523862 ***

Note You need to log in before you can comment on or make changes to this bug.