Bug 52440 - iSCSI service fails to shutdown upon reboot
Summary: iSCSI service fails to shutdown upon reboot
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: iscsi   
(Show other bugs)
Version: 7.3
Hardware: ia64 Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-23 19:10 UTC by Joshua Giles
Modified: 2007-04-18 16:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-28 20:37:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joshua Giles 2001-08-23 19:10:14 UTC
Description of Problem:
iSCSI daemon fails to shutdown upon executing "reboot" command.
When the screen goes to a virtual console, the service "iSCSI" fails
to shutdown.

Version-Release number of selected component (if applicable):


How Reproducible:
100%

Steps to Reproduce:
1. shutdown or reboot system 
2. 
3. 

Actual Results:



Expected Results:
Shutdown of the service should occur.

Additional Information:
This happened on several i686 machines(smp,up) as well as the ia64 on the 
smp kernel all with different hardware configs.

Comment 1 Glen Foster 2001-08-24 17:08:50 UTC
This defect is considered SHOULD-FIX for Fairfax.

Comment 2 Bob Matthews 2001-08-25 22:20:07 UTC
Michael,

I'm foisting this to you.

Comment 3 Michael K. Johnson 2001-08-27 12:37:17 UTC
Are you enabling iscsi?

If you are not enabling iscsi, then it won't create /var/lock/subsys/iscsi
because the start script won't complete

Comment 4 John A. Hull 2001-08-28 17:25:19 UTC
We don't touch iSCSI in our testing. The defaults at installation are what we 
are using. It fails shutdown on all systems.

Comment 5 Michael K. Johnson 2001-08-28 20:27:01 UTC
It should fail to shutdown, because it shouldn't start, because there
is no config.

Am I not understanding you correctly?

Comment 6 John A. Hull 2001-08-28 20:37:29 UTC
Hmmm...I think we're on the same page. We don't start iSCSI, so it shouldn't 
fail to shut down, because it already is.

Comment 7 Michael K. Johnson 2001-08-28 23:36:04 UTC
I finally understood what you were trying to say.  Should be fixed in
the -2 package.

Fortunately, it was only noise.

iscsid was looking at iscsi.conf, seeing no drives, and exiting.  So
iscsid wasn't there to stop afterwards, so it complained.

Thanks


Note You need to log in before you can comment on or make changes to this bug.