Bug 524414 - Cracking sound with snd-intel8x0
Summary: Cracking sound with snd-intel8x0
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jaroslav Kysela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-19 22:54 UTC by Eric Moret
Modified: 2009-10-21 10:25 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-21 10:25:32 UTC
Type: ---


Attachments (Terms of Use)
alsa-info (21.87 KB, text/plain)
2009-09-23 03:04 UTC, Eric Moret
no flags Details

Description Eric Moret 2009-09-19 22:54:58 UTC
Description of problem:
I experience cracking noise when some audio starts playing. I used testday-20090915-i686.iso I have uninstalled alsa-plugins-pulseaudio and still experience the issue. This is u

How reproducible:
Always

Steps to Reproduce:
Boot testday-20090915 click the audio volume control in the gnome tray area and adjust volume. When mouse button is released, a cracking noise is heard then the sound associated with the volume adjustment is played.

Additional information:
smolt profile: http://www.smolts.org/client/show/pub_f1add070-8fea-42ca-8deb-555cf1282436

Comment 1 Eric Moret 2009-09-20 00:22:29 UTC
BTW, here are relevant component versions:

pulseaudio-0.9.17-1.fc12.i686
alsa-plugins-pulseaudio-1.0.21-2.fc12.i686
kernel-2.6.31-14.fc12.i686

Comment 2 Adam Williamson 2009-09-22 19:57:45 UTC
Can we get your alsa-info.sh as described in the Test Day instructions, please? Thanks.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Eric Moret 2009-09-23 03:04:15 UTC
Created attachment 362160 [details]
alsa-info

Comment 4 Chuck Ebbert 2009-09-27 11:00:09 UTC
We have a patch in F-12 for the Intel HDA audio but nothing for intel8x0. You can work around this by adding 'powersave=0' to the module options. I guess if this isn't fixed we can change the default back to 0.

Comment 5 Eric Moret 2009-09-29 05:39:01 UTC
I put the following in /etc/rc.local which solved the problem

$ echo 0 > /sys/module/snd_ac97_codec/parameters/power_save

Let me know if I should try something else

Comment 6 Chuck Ebbert 2009-10-21 10:25:32 UTC
No workaround for AC97 seems to be available. Set the default to 0 in kernel-2.6.31.5-90.rc1.fc12


Note You need to log in before you can comment on or make changes to this bug.