Bug 524438 - mac80211-based wireless: Random 20-30 seconds of disconnection
Summary: mac80211-based wireless: Random 20-30 seconds of disconnection
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 531210 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-20 07:55 UTC by Alex Betis
Modified: 2010-02-24 09:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-08 14:42:09 UTC


Attachments (Terms of Use)

Description Alex Betis 2009-09-20 07:55:21 UTC
Description of problem:
I have:
05:02.0 Network controller: RaLink RT2561/RT61 802.11g PCI
        Subsystem: RaLink EW-7108PCg
        Flags: bus master, slow devsel, latency 64, IRQ 23
        Memory at fbff8000 (32-bit, non-prefetchable) [size=32K]
        Capabilities: [40] Power Management version 2
        Kernel driver in use: rt61pci
        Kernel modules: rt61pci

After upgrade to Fedora-11 I experience random disconnects for 20-30 seconds while working with the device. The long blackout is enough to disconnect SSH or VNC session that I generally use to connect to the remote PC.

Right now my kernel is:
2.6.30.5-43.fc11.i686.PAE

The same happened with:
2.6.29.6-217.2.16.fc11.i686.PAE

With Fedora-10 and Fedora-9 I did not experience the problem (I don't remember the kernel versions that was used).

I've looked for similar bug reports and found something related to scan while connected that cause a short disconnect. That's not the same as I experience since I don't have any supplicant entries in the log, in fact, nothing appears in the log. Tried to initiate scan manually, it takes only 0.8 seconds and doesn't break the connection for 20-30 seconds, so that's probably not the same issue.

Version-Release number of selected component (if applicable):
1.2-5

How reproducible:
Happens randomly, I think it happens more frequent when high traffic is transferred.

Steps to Reproduce:
1. Connect
2. ping the remote PC that is connected with wifi
3. Observe 20-30 blackouts in pings
  
Actual results:
20-30 seconds disconnection in the link, generally reconnected only when pinging from the Wifi connected PC to outside world.

Expected results:
Constant connection.

Additional info:
Please let me know if I can provide more info to help debugging that issue.

Comment 1 Nicolas Chauvet (kwizart) 2009-09-22 22:29:43 UTC
re-assigned to the kernel since the firmware used to be rather stable though time...

Comment 2 Alex Betis 2009-09-28 10:46:30 UTC
Are there any logs I can try to collect to make sure where the problem might be?

Comment 3 John W. Linville 2009-10-28 17:45:33 UTC
*** Bug 531210 has been marked as a duplicate of this bug. ***

Comment 4 Alex Betis 2009-10-28 19:38:10 UTC
An update: I've installed Ubuntu 9.10 beta with kernel 2.6.31-14, the disconnections still happen.
Not sure if it's less frequent, but it's still happen.

Comment 5 John W. Linville 2009-10-28 19:54:55 UTC
You are a victim of periodic scanning.  Hopefully 2.6.32 will make that scanning less expensive.

Comment 6 Tomas Linden 2009-10-28 21:49:42 UTC
I run the command
  watch -n 1 iwconfig wlan0
which showed that when the network break occurs the WLAN card is indeed scanning over frequencies. The Atheros AR5001X+ 802.11a/b/g card that I have supports radiochannels at 2.4 GHz and 5.15 GHz. For me the network connection is kept to the access point after the frequency scanning has stopped. Alex Betis reports in bug 524438 disconnections which I don't see in bug 531210. Do you think that the bugs are the same in spite of that? 

Is there any way of preventing this frequency scanning?

Comment 7 Alex Betis 2009-11-13 13:44:54 UTC
Gents, can anyone respond and propose a workaround to prevent the automatic frequency scanning?

Comment 8 John W. Linville 2009-11-13 14:17:17 UTC
None that are very good..."don't use NetworkManager" is the only one that is reasonably easy to implement (other than waiting for a kernel update) -- sorry!

Comment 9 John W. Linville 2010-01-21 14:59:04 UTC
Have you tried a 2.6.32-based kernel build from Koji?

http://koji.fedoraproject.org/koji/buildinfo?buildID=152098

Comment 10 Alex Betis 2010-02-07 11:59:32 UTC
No I did't, I prefer to stick to Ubuntu's delivered kernels for now, which is 2.6.31-19.

Comment 11 John W. Linville 2010-02-08 14:42:09 UTC
I see...well, good luck!

Comment 12 Tomas Linden 2010-02-24 09:11:24 UTC
I'm running Fedora 11, so I installed the Koji kernel
  Linux pc78 2.6.32.8-29.rc2.fc11.i586 #1 SMP Sun Feb 7 23:26:54 UTC 2010 i686 i686 i386 GNU/Linux

Connecting to the acccess point failed several times but eventually a connection was made. I tested the connection with ping and unfortunately the situation is still the same that the scanning occurs, which leads to packet losses.

Is it normal that lspci reports my card as
  02:00.0 Ethernet controller: Atheros Communications Inc. Atheros AR5001X+ Wireless Network Adapter (rev 01)
while the ath5k driver gives a slightly different identification?
  ath5k phy0: Atheros AR5212 chip found (MAC: 0x56, PHY: 0x41)


Note You need to log in before you can comment on or make changes to this bug.