Bug 524462 - Sudden "white noise" with pulseaudio
Summary: Sudden "white noise" with pulseaudio
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 11
Hardware: i586
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jaroslav Kysela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-20 14:24 UTC by Ralph Angenendt
Modified: 2009-11-27 22:23 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-27 22:23:17 UTC


Attachments (Terms of Use)
alsa-info --no-upload for the machine in question (9.75 KB, text/plain)
2009-09-29 11:35 UTC, Ralph Angenendt
no flags Details

Description Ralph Angenendt 2009-09-20 14:24:08 UTC
Description of problem:

I have two main applications using pulseaudio. One is xbmc (which keeps its pulseaudio channel open all the time), the other is mpd, which just connects to pulseaudio when it is actually playing. 

From time to time (two hours after a pulseaudio restart, several days after a pulseaudio restart) the music I play through mpd is suddenly replaced by white noise. All mixers are set to 100% (pulseaudio out, alsactl, mpd out, xbmc out)

When this happens, lowering the volume within mpd brings me to a level where the white noise goes away and I can listen to music again. Changing xmbc's output level and/or pulseaudio's general output level can help too. If I set it too low, music is distorted again, so the bracket in which a clear sound can be heard is very slim.

When the white noise suddenly appears nothing is logged, although the log level is set to debug. Setting this is the only change to the standard daemon.conf

Restarting pulseaudio brings the system back to the expected behaviour.

This is pretty bad, especially if you listen to music via headphones, as the white noise appears without warning.

Version-Release number of selected component (if applicable):

alsa-utils-1.0.21-2.fc11.i586
alsa-lib-1.0.21-3.fc11.i586
pulseaudio-0.9.15-17.fc11.i586

How reproducible:

Keep playing music.


Actual results:

Bleeding ears

Expected results:

Ears not bleeding, but okay.

Additional info:

Is there anything to make pulseaudio more talkative?

Comment 1 Lennart Poettering 2009-09-29 04:19:16 UTC
Smells like a hw/driver issue to me.

The highest log level of PA is "debug", so if no output is generated when this happens this wasn't triggered by any state change in PA.

Which driver is this?

Please include the output alsa-info --no-upload generates here.

Comment 2 Ralph Angenendt 2009-09-29 11:34:17 UTC
I didn't have this problem (no, no pulseaudio rant here) running on F10 with pulseaudio removed. So either something has changed in alsa or alsa and pulse don't play together well in this case ... 

But as removing pulseaudio on F11 removes bluez which I need, I cannot go that route.

Comment 3 Ralph Angenendt 2009-09-29 11:35:12 UTC
Created attachment 362997 [details]
alsa-info --no-upload for the machine in question

Comment 4 Ralph Angenendt 2009-11-27 22:23:17 UTC
Sorry, looks like it really is a hardware problem and the timing of the issue was just too good. After exchanging the sound hardware this hasn't happened anymore.


Note You need to log in before you can comment on or make changes to this bug.