Bug 52449 - I get spaces at the start of the line I type in when using ircii's /window create facility
I get spaces at the start of the line I type in when using ircii's /window cr...
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: ircii (Show other bugs)
7.3
i386 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-23 16:10 EDT by Telsa Gwynne
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-06 15:42:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Telsa Gwynne 2001-08-23 16:10:35 EDT
Description of Problem:

When using ircii's /window create facility, occasionally blank spaces
are put at the start of the line you type in as you switch to the other
window. 

Version-Release number of selected component (if applicable):

ircii-4.4Z

How Reproducible:

Intermittent :(

Steps to Reproduce:

I have long used the /window new facility of ircii which splits the
current terminal into sections. I tried the /window create facility
because I was running out of space. It creates an xterm on the same
server with the same username for you. (Even if you start it from
gnome-terminal originally.)

Whilst engaged in several conversations in the resulting windows, I
saw that the cursor was starting not at the left-hand edge of the
screen but sometime from somewhere in the middle. It was intermittent.
It also _seemed_ to have something to do with where the last line which
ircii had sent me ended. 

The best way to hope to reproduce: 

gnome-terminal or xterm.
$ irc username servername
Wait until on server. 
/window create
Wait for new xterm to show up.
On each window, join different channel. I think your chances are best
if they have at least some level of activity.
Join in conversation or type commands such as /date, /links, /whois person
which don't show up to other people. 
Do this on both windows.
Watch the position of the cursor carefully as you swap windows. 
Eventually you'll notice it's not always where you expect. 

I have seen some other oddnesses with this: delete/backspace don't
always do quite what I expect (you can't seem to get rid of the final
character in a line you're trying to edit for example). 

Actual Results:

Cursor not always at start of input line (whatever it's called) when
you swap between windows. Using delete (okay, backspace key, moving
cursor left one) doesn't work as expected. Using ^A will put your
cursor where you expect. 

Expected Results:

Cursor at start of line consistently. No need for ^A.

Additional Information:
	
This occurs starting ircii from a gnome-terminal or an xterm. I have
not tried with rxvt (sorry)
Comment 1 Jeremy Katz 2002-01-17 19:08:26 EST
ircii has been replaced for future releases with epic as it has similar
functionality (and compatible scripting) with some more features.  I haven't
been able to reproduce it in epic, but if you do, feel free to open a bug there :)

Note You need to log in before you can comment on or make changes to this bug.