Bug 524495 - Default output media type for printing is wrong
Summary: Default output media type for printing is wrong
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xpdf
Version: 11
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-20 20:01 UTC by davidwillmore
Modified: 2010-06-28 14:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-28 14:44:57 UTC


Attachments (Terms of Use)

Description davidwillmore 2009-09-20 20:01:10 UTC
Description of problem:
When xpdf is opened on a .pdf file with the page size/media type of Letter, and the 'print' button is pressed and then 'print to file' is slected, the resulting .ps file will have a media type of A4.  It should have the same media type as the input file. The default should be the same as specifying '-paper match' on the command line.  This would cause xpdf to generate output PostScript files with the same media type as the .pdf file being displayed.

Version-Release number of selected component (if applicable):
xpdf-3.02-13.fc11.i586

How reproducible:
Completely

Steps to Reproduce:
1. Open a .pdf file with the media type of Letter
2. "print to file"
  
Actual results:
The output file will have a media type of A4.

Expected results:
The output should have a media type of Letter--same as the input file.

Additional info:
The .pdf file I used was http://csrc.nist.gov/publications/fips/fips197/fips-197.pdf

Comment 1 Tom "spot" Callaway 2010-01-04 15:24:10 UTC
Are you sure about this? When I tried to reproduce this issue with the fips-197.pdf, the .ps output was formatted Letter (according to evince).

Do you have something set in /etc/papersize?

I'd like to be able to reproduce this bug before I write a patch to fix it. :)

Comment 2 davidwillmore 2010-01-04 17:21:28 UTC
I'm afraid that environment no longer exists.  The machine in question has been moved to F12 and no longer evidences the problem.  I'll see if I can find the old archive of it before the upgrade and see about the contents of that file.

Comment 3 Tom "spot" Callaway 2010-01-04 17:30:11 UTC
Hmm, its odd that F12 wouldn't also have the same issue... let me know if you are unable to reproduce, and I'll build a F11 instance.

Comment 4 EMR_Fedora 2010-01-29 19:41:09 UTC
F12 has the same issue, but F11 for me did not. I am using F12 x86_64 and F11 x86_64. Below are my findings...

The only benchmark that I am using is configuring KMail and printing an email message. I am also using Firefox and printing a web page. I have tried other Gnome Vs. KDE applications and noticed that the KDE apps consistently default to A4 instead of my set default of US-Letter. 

I think I have been able to reproduce the problem consistently, and have narrowed it down to the following:

1) If I use the system-config-printer, and add an HP LaserJet 4200 Series printer via JetDirect, it selects a Postscript driver as the default (Make/Model): "HP LaserJet 4200 Series Postscript (recommended)"

When I print to that from Kmail/KDE the printer asks for A4 paper even though the defaults are set to US-Letter.

2) If I change the printer driver (Make/Model) to "HP LaserJet 4200 - CUPS+Gutenprint v5.2.4" when I print from KMail/KDE the printer correctly uses US-Letter.

Is this a bug?

However, while Kmail prints to the CUPS+Guten driver OK, Okular still insists on printing/formatting the page for A4 even though I have selected US-Letter and the default is US-Letter. Also, I tried to print with KMail from Gnome and it also was messed up.

In fact, I tried to print to a PDF file with firefox, kmail, and okular with the gnome based applications it correctly selected my default of US-Letter. Kmail and Okular, from within Gnome *and* KDE when I printed to a file, it selected A4 instead of my default. Printing to a file does NOT allow me to select a paper size.

Comment 5 Bug Zapper 2010-04-28 10:29:54 UTC
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 6 Bug Zapper 2010-06-28 14:44:57 UTC
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.